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Unisphere pour PowerMax : SMAS continue de se bloquer avec l’erreur « Address already in use: bind 127.0.0.1:9999 »

Résumé: Le SMAS tombe en panne en 5 secondes

Cet article a peut-être été traduit automatiquement. Si vous avez des commentaires concernant sa qualité, veuillez nous en informer en utilisant le formulaire au bas de cette page.

Contenu de l’article


Symptômes

Unisphere for PowerMax nouvellement installé ne peut pas être lancé
SMAS tombe en panne dans les 5 secondes
Dans certains scénarios, seul run.log est généré car SMAS n’a jamais fonctionné correctement après l’installation
Dans certains scénarios, smas.log est également généré

Les erreurs ci-dessous sont visibles

dans tous les journaux Erreur msg (smas.log):
 
[Contrôleur hôte] ERREUR 21:43:20,514 [org.jboss.msc.service.fail] (thread de service MSC 1-2) MSC00001: Échec du démarrage du service jboss.remoting.server.management: org.jboss.msc.service.StartException
dans service jboss.remoting.server.management: JBAS017112: Adresse déjà utilisée: bind 127.0.0.1:9999

Erreur msg (run.log):
 
[Contrôleur hôte] 21:43:20,529 FATAL [org.jboss.as.host.controller] (Thread de démarrage du contrôleur) xxxx010933: Le démarrage du contrôleur hôte a échoué de manière irrécupérable; Sortie. Pour plus d’informations, reportez-vous aux messages précédents.
[Contrôleur hôte] 21:43:20,576 INFO [org.jboss.as] (thread de service MSC 1-5) xxxx015950: JBoss AS 7.1.3a. OCI-emc " xxxxx " arrêté en 9 ms
21:43:21,075 INFO [org.jboss.as.process.Host Controller.status] (reaper for Host Controller) xxxx012010: Le processus « Host Controller » s’est terminé avec l’état de sortie 99
21:43:21,075 INFO [org.jboss.as.process] (Thread-8) xxxx012016: Arrêt du contrôleur
de processus 21:43:21,075 INFO [org.jboss.as.process] (Thread-8) xxxx012015: Tous les processus sont terminés; exiting

[Host Controller] ]) - description de l’échec: {"WFLYCTL0080: Failed services » => {"jboss.remoting.server.management » => « WFLYRMT0004: Adresse déjà utilisée: bind 127.0.0.1:9999

 

Cause

Les erreurs ci-dessus signifient qu’il existe un groupe de ports Unisphere avec une autre application

Résolution

Unisphere for VMAX/PowerMax doit être installé avec un accès exclusif aux ports ci-dessous: 
  • 8443 pour https
  • 3324 pour SMAS_DB
  • 8088, 8089 pour RCA, RT
  • 4447, 9990, 9999 pour le serveur Unisphere for VMAX (non modifiable)
    • Le port :9999 est utilisé comme communication intra-service. Il est communément appelé MANAGEMENT_NATIVE.
  • 5988/5989 pour ECOM
  • 2707 pour client/serveur
  • 10123 pour vWitness

Pour résoudre ce problème, identifiez l’application qui utilise l’un des ports ci-dessus et désinstallez-la. Démarrez ensuite SMAS normalement.
Dans certains cas, une réinstallation de Unisphere peut être nécessaire.

Voici quelques-unes des applications dans lesquelles de telles vulnérabilités ont été observées:
Splunk
CISCO
Dell EMC Data Protection Advisor (DPA)
AppSync

Propriétés de l’article


Produit concerné

Unisphere for VMAX, Unisphere for PowerMax

Produit

Unisphere for VMAX

Dernière date de publication

08 sept. 2023

Version

3

Type d’article

Solution