Přeskočit na hlavní obsah
  • Vkládejte objednávky snadno a rychle
  • Zobrazit objednávky a sledovat stav expedice
  • Vytvořte a přistupujte k seznamu svých produktů
  • Spravujte své profily, produkty a kontakty na úrovni produktů na stránkách Dell EMC pomocí správy společnosti.

Unisphere for PowerMax: SMAS selhává a zobrazuje se chyba "Address already in use: bind 127.0.0.1:9999"

Shrnutí: SMAS se spadne na 5 sekund

Tento článek byl zřejmě přeložen automaticky. Máte-li připomínky k jeho kvalitě, informujte nás pomocí formuláře ve spodní části stránky.

Obsah článku


Příznaky

Nově nainstalovanou aplikaci Unisphere for PowerMax nelze spustit
, upustí se paměť SMAS během 5 sekund
. V některých případech se vygenerují pouze soubory run.log, protože paměť SMAS po instalaci
nikdy nespustila správně. V některých případech se také generují níže uvedené

chyby smas.log ve všech protokolech

Error msg (smas.log):
 
[Host Controller] 21:43:20,514 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-2) MSC00001: Nepodařilo se spustit službu jboss.remoting.server.management: org.jboss.msc.service.StartException
ve službě jboss.remoting.server.management: JBAS017112: Adresa se již používá: vazba 127.0.0.1:9999

Chybová zpráva msg (run.log):
 
[Host Controller] 21:43:20,529 FATAL [org.jboss.as.host.controller] (Controller Boot Thread) xxxx010933: Spuštění hostitelského řadiče selhalo neobnovitelným způsobem. Ukončení. Podrobnosti naleznete v předchozích zprávách.
[Host Controller] 21:43:20,576 INFO [org.jboss.as] (MSC service thread 1-5) xxxx015950: JBoss AS 7.1.3a. OCI-emc "xxxxx" zastaveno v 9
ms 21:43:21,075 INFO [org.jboss.as.process.Host Controller.status] (znovu se zobrazí u hostitelského řadiče) xxxx012010: Proces "Host Controller" byl dokončen se stavem ukončení 99
21:43:21,075 INFO [org.jboss.as.process] (Thread-8) xxxx012016: Vypnutí řadiče
procesu 21:43:21,075 INFO [org.jboss.as.process] (Thread-8) xxxx012015: Všechny procesy jsou dokončeny. exiting

[Host Controller] ]) – popis selhání: {"WFLYCTL0080: Failed services" => {"jboss.remoting.server.management" => "WFLYRMT0004: Adresa se již používá: vazba 127.0.0.1:9999

 

Příčina

Výše uvedené chyby znamenají, že u některých jiných aplikací dochází k lomu portů Unisphere.

Řešení

Je třeba nainstalovat software Unisphere for VMAX/PowerMax s exkluzivním přístupem k níže uvedených portům: 
  • 8443 pro protokol https
  • 3324 pro SMAS_DB
  • 8088, 8089 pro RCA, RT
  • 4447, 9990, 9999 pro unisphere pro server VMAX (nelze je upravit)
    • Port: 9999 se používá jako komunikace v rámci služby – běžně se označuje jako MANAGEMENT_NATIVE.
  • 5988/5989 pro ECOM
  • 2707 pro klient/server
  • 10123 pro vWitness

Chcete-li tento problém vyřešit, identifikujte aplikaci, která využívá některý z výše uvedených portů, a odinstalujte ji. Poté normálně spusťte klávesu SMAS.
V některých případech může být vyžadována opakovaná instalace nástroje Unisphere.

Následují některé aplikace, ve kterých byly tyto lomy pozorovány:
Splunk
CISCO
Dell EMC Data Protection Advisor (DPA)
AppSync.

Vlastnosti článku


Dotčený produkt

Unisphere for VMAX, Unisphere for PowerMax

Produkt

Unisphere for VMAX

Datum posledního vydání

08 zář 2023

Verze

3

Typ článku

Solution