跳至主要內容
  • 簡單快速地下訂單
  • 檢視訂單及追蹤商品運送狀態
  • 建立並存取您的產品清單
  • 使用「公司管理」來管理您的 Dell EMC 網站、產品和產品層級連絡人。

Windows 8 和 Windows 8.1 的停止錯誤 (藍色畫面) 故障診斷

摘要: 本文有助於診斷和解決 Windows 8.1 系統上的藍色螢幕錯誤。

本文可能採用自動翻譯。如果您對翻譯品質有任何寶貴意見,請使用此頁面底部的表單告訴我們,謝謝。

文章內容


症狀

目錄:

  1. 什麼是藍屏錯誤?
  2. 查看問題與解決方案控制中心
  3. 執行線上診斷
  4. 故障排除常見的藍色畫面錯誤訊息
    1. 無法掛接的開機磁片區和無法存取的開機裝置
    2. NTFS 檔案系統
    3. 未處理系統執行緒外泄,且未處理核心模式例外狀況
    4. 非分頁區域的分頁錯誤
    5. 驅動程式 IRQL 不小於或等於
    6. 執行緒卡在設備磁碟機中
  5. 尋找錯誤訊息的相關資訊

本文適用于 Microsoft Windows 8。
按一下下方以變更作業系統。


故障診斷 Windows 中的藍色畫面問題

持續時間:03:58
關閉標題:以多種語言提供按一下[Closed Caption] (關閉標題) 圖示,然後選取您想要的語言。


什麼是藍屏錯誤?

當 Windows 遇到特定情況時,它會停止並將產生的診斷資訊以白色文字顯示在藍色畫面上。這些錯誤的出現是「Blue Screen」或「Blue Screen」一詞的來源。若為 Windows 8,藍色畫面已變更,現在會顯示 ASCII 滿面,並顯示「您的電腦遇到無法處理的問題,現在必須重新開機」,接著是錯誤類型。已移除熟悉的「OxXXXXXXXXXX」錯誤代碼。
當下列情況出現藍色畫面錯誤:

  • Windows 偵測到在不遺失資料的情況下無法從中復原的錯誤
  • Windows 偵測到重要作業系統資料已損毀
  • Windows 偵測到硬體以無法修復的方式故障
  • 這些年來,顯示的確切文字從 Windows NT 4.0 中資訊密集的牆面,轉變為現代版 Windows 所使用的相對簡約訊息。

步驟 1:查看問題與解決方案控制中心

動作中心會收集 Windows 8 當機錯誤,並參考線上提供的其他當機資料。若要存取重要訊息中心,請依照以下指示操作:

  1. 在「開始」畫面輸入「問題報告與解決方案」,然後選取「檢視所有問題報告」,以檢視電腦上發生的錯誤清單及其可能的解決方案,例如更新驅動程式、更新系統 BIOS 或檢查軟體更新。
  2. 替代說明:
    1. 從螢幕右側撥動以開啟快速鍵列 (如果使用滑鼠,請將滑鼠移至螢幕右上角,然後將指標向下移動以開啟快速鍵列),然後選取「設定」。或者,按下 Windows + I鍵,直接前往「設定快速鍵」。
    2. 選取控制台
    3. 選取「系統與維護」。
    4. 選取問題報告和解決方案。

步驟 2:執行線上診斷

Dell 已建立一組線上診斷程式,可識別可能造成此問題的電腦硬體或組態問題。流覽至Dell 線上診斷程式以取得更多資訊並執行電腦掃描。


步驟 3:故障排除常見的藍色畫面錯誤訊息


無法掛接的開機磁片

區無法存取開機裝置

這兩個錯誤都有類似的原因,這兩個錯誤都適用相同的故障診斷步驟。這些停止代碼一律會在啟動程式期間發生。當您遇到其中一個停止代碼時,已發生下列情況:

  1. 系統已完成開機自我測試 (POST)。
     
  2. 系統已載入 NTLDR,並將啟動程式的控制轉移至 NTOSKRNL (核心)。
     
  3. NTOSKRNL 很困惑。無論是找不到其他專案,還是無法讀取其認為儲存位置的檔案系統。
    疑難排解此錯誤時,您的工作是找出 Windows 核心混淆的原因,並修正混淆的原因。
要檢查事項
  • 系統 BIOS 中的 SATA 控制器組態如果 SATA 控制器從 ATA 切換到 AHCI 模式 (反之亦然),則 Windows 無法與 SATA 控制器對談,因為不同的模式需要不同的驅動程式。嘗試在 BIOS 中切換 SATA 控制器模式。
  • RAID 設定如果您使用 RAID 控制器設定進行實驗,可能會收到此錯誤。嘗試將 RAID 設定變更為 Autodetect (通常正確)。
  • 不正確或未正確安裝的佈線嘗試重新安裝連接磁片磁碟機及其控制器兩端的資料纜線。
  • 硬碟故障在硬碟上執行內建診斷程式。請記得:程式碼 7代表可修正的資料損毀,而非磁片故障。
  • 檔案系統損毀從 Windows 安裝磁片啟動復原主控台,然後執行chkdsk /f /r
  • 未正確設定開機。INI (Windows Vista)如果您不經意清除或修改 boot.ini 檔案,您可能會在啟動程式期間收到停止代碼0x7B。從 Windows 安裝磁片啟動復原主控台,並執行BOOTCFG /REBUILD

NTFS_FILE_SYSTEM

此停止代碼表示 NTFS 檔案系統驅動程式遇到無法處理的情況,而且幾乎一律是由 3 件事所造成:

  • 磁片上的資料損毀
  • 記憶體中的資料損毀
  • 系統完全耗盡記憶體 (通常只會在大量載入的伺服器上發生)
要檢查事項
  1. 重新接插記憶體和所有磁片磁碟機資料纜線,避免因硬體安裝不良或不正確而產生資料損毀問題。
     
  2. 執行完整的記憶體和硬碟診斷。此處的快速測試不夠完整。您必須執行完整的系統診斷程式。
     
  3. 如果這些診斷通過,請從復原主控台 (chkdsk /f /r) 執行完整檔案系統檢查,以偵測並 (可能) 修復任何損毀的資料。
     
  4. 如果以上皆未解決此問題,請重新安裝 Windows。
     
  5. 如果這樣做無法解決問題,請更換硬碟。

     


未處理系統執行緒外泄未處理

的核心模式例外狀況

這兩個錯誤表示在核心中執行的程式遇到無法復原的意外狀況。它們的故障診斷和解決步驟完全相同,您可能需要使用 Windows 偵錯程式來找出造成錯誤的原因。

要檢查事項
  • 如果藍色畫面訊息提到驅動程式或程式庫檔案,請找出檔案的一部分驅動程式或應用程式,並更新或停用。
  • 將系統 BIOS 更新至最新的可用版本。
  • 卸載最近安裝的任何程式,並回復任何最近安裝的驅動程式。
  • 在電腦記憶體上執行診斷程式。
 

非分頁區域的分頁錯誤

此停止代碼表示系統嘗試存取不存在的記憶體,幾乎總是因為:

  • 嘗試存取不存在的記憶體頁面的驅動程式
  • 系統服務 (例如病毒掃描器) 以優異的方式失敗
  • 記憶體故障或未正確安裝
  • 硬碟上的資料損毀

使用 Windows 偵錯器來找出這些錯誤的確切原因。

要檢查事項
  1. 如果藍色畫面錯誤提到驅動程式或程式庫檔案,請找出檔案的一部分,以及升級至最新版本或卸載驅動程式或程式的驅動程式或程式。
     
  2. 如果在啟動程式期間發生錯誤,請嘗試開機至「Last Known Good Configuration」。
     
  3. 如果在安裝程式或驅動程式後開始出現錯誤,請卸載該程式或驅動程式。
     
  4. 重新接插記憶體和硬碟資料纜線後,請嘗試執行完整的硬碟和記憶體診斷程式。

 

驅動程式 IRQL 不小於或等於

此停止代碼表示當驅動程式不應該存取特定區域的記憶體時,表示驅動程式本身存在瑕疵。疑難排解的目標是找出該驅動程式,並停用或更換。使用 Windows 偵錯程式對此錯誤進行故障診斷。
在未偵錯的情況下,您只能卸載/更新/回溯包含藍色畫面提到的驅動程式檔案的驅動程式。


執行緒卡在設備磁碟機中

此藍色畫面錯誤表示設備磁碟機幾乎永遠都是影像卡驅動程式,因此在等待某件事情 (通常是硬體作業) 時卡住。您大部分可能已看到與此藍色畫面相關的 nv4_disp.sys

要檢查事項:
  1. 請確定影像驅動程式已更新為最新的 Dell 版本。
     
  2. 系統 BIOS 完全處於最新狀態。
     
  3. 如果影像驅動程式和系統 BIOS 皆完全處於最新狀態,請向製造商確認是否有最新的驅動程式更新。
     
  4. 做為最後手段,請嘗試交換顯示配接器。
注意:重新安裝 Windows 並不太可能防止此錯誤再次發生。

 

其他資訊

如果這些解決方案尚未解決您的問題,請嘗試在 Web 上搜尋其他解決方案。
按一下下方您偏好的搜尋引擎,然後說明您的問題,包括任何特定的錯誤訊息。

 
注意:Microsoft 錯誤檢查代碼參考 網站包含廣泛的藍色畫面錯誤代碼說明清單和可能的原因。如果您已記錄 STOP 0xXXXXXX 代碼,且上述步驟無法解決您的問題,請嘗試在此網站上向上尋找。
 

搜尋 Dell Search  Microsoft  Search Google  Search Bing  此超連結會帶您前往 Dell Technologies 以外的網站

 

原因

沒有可用的原因資訊。

解析度

沒有可用的解決方案資訊。

文章屬性


受影響的產品

Inspiron, Latitude, Vostro, XPS, Fixed Workstations

上次發佈日期

14 9月 2023

版本

5

文章類型

Solution