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Unisphere for PowerMax: SMAS keeps crashing with error "Address already in use: bind 127.0.0.1:9999"

Summary: SMAS going down with 5 seconds

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Symptoms

Newly installed Unisphere for PowerMax cannot be launched
SMAS drops down within 5 seconds
In some scenarios only run.log is generated because SMAS never ran fine after installation
In some scenarios smas.log is also generated

Below errors are seen in all the logs

Error msg (smas.log):
 
[Host Controller] 21:43:20,514 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-2) MSC00001: Failed to start service jboss.remoting.server.management: org.jboss.msc.service.StartException 
in service jboss.remoting.server.management: JBAS017112: Address already in use: bind 127.0.0.1:9999

Error msg (run.log):
 
[Host Controller] 21:43:20,529 FATAL [org.jboss.as.host.controller] (Controller Boot Thread) xxxx010933: Host Controller boot has failed in an unrecoverable manner; exiting. See previous messages for details.
[Host Controller] 21:43:20,576 INFO  [org.jboss.as] (MSC service thread 1-5) xxxx015950: JBoss AS 7.1.3a.OCI-emc "xxxxx" stopped in 9ms
21:43:21,075 INFO  [org.jboss.as.process.Host Controller.status] (reaper for Host Controller) xxxx012010: Process 'Host Controller' finished with an exit status of 99
21:43:21,075 INFO  [org.jboss.as.process] (Thread-8) xxxx012016: Shutting down process controller
21:43:21,075 INFO  [org.jboss.as.process] (Thread-8) xxxx012015: All processes finished; exiting

[Host Controller] ]) - failure description: {"WFLYCTL0080: Failed services" => {"jboss.remoting.server.management" => "WFLYRMT0004: Address already in use: bind 127.0.0.1:9999

 

Cause

Above errors means there is a clash of Unisphere ports with some other application

Resolution

Unisphere for VMAX/PowerMax needs to be installed with exclusive access to the below ports: 
  • 8443 for https
  • 3324 for SMAS_DB
  • 8088, 8089 for RCA, RT
  • 4447, 9990, 9999 for the Unisphere for VMAX server (non editable)
    • Port :9999 is used as the intra-service communication – it is commonly referred to as MANAGEMENT_NATIVE.
  • 5988/5989 for ECOM
  • 2707 for client/server
  • 10123 for vWitness

In order to resolve this issue, identify the application which is utilizing any of the above ports and uninstall it. Then start SMAS normally.
In some scenario, a re-install of Unisphere may be required.

Following are some of the applications in which such clashes were observed:
Splunk
CISCO 
Dell EMC Data Protection Advisor (DPA)
AppSync

Article Properties


Affected Product

Unisphere for VMAX, Unisphere for PowerMax

Product

Unisphere for VMAX

Last Published Date

08 Sept 2023

Version

3

Article Type

Solution