Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

How to Find the Product Model of your Dell Computer

Summary: This article provides information about how to identify the product model number for your Dell computer. Identifying the product model number allows you to get model-specific support such as drivers, manuals, specifications, and capabilities. ...

This article may have been automatically translated. If you have any feedback regarding its quality, please let us know using the form at the bottom of this page.

Article Content


Symptoms

NOTE: Dell recommends allowing the Dell.com/support website to detect your Dell computer using SupportAssist or entering your Dell computer's Service Tag or Express Service Code to identify the product model number and get personalized support.

Different methods to find the model number of your Dell computer

  1. Using the product label on your Dell computer
  2. Using the Dell SupportAssist app for Microsoft Windows
  3. Using the Windows System Information utility
  4. Using your Dell computer's BIOS

Cause

Identifying the product model number allows you to get model-specific support such as drivers, manuals, specifications, and capabilities.

Resolution

Method 1: Using the product label on your Dell computer

For most Dell computers, you can find the product model number on a label or sticker that is on the outside of the case.

  • Dell laptops - Bottom cover, base, battery compartment, screen, keyboard trim, or palm rest.
  • Dell desktops and all-in-ones - On the top panel, back panel, or side panel of the tower case, lower back or stand on an all-in-one computer.
  • Dell tablets - Screen or back panel.
Back to top

Method 2: Using the Dell SupportAssist app for Microsoft Windows

SupportAssist is a Dell application that comes installed on your computer. It uses updates and proactive resolution features to help identify and prevent issues. When you open the application, your product model is displayed.

To find your product model using SupportAssist

Windows 11 and Windows 10

  1. In the Search Box, type SupportAssist.
  2. Select SupportAssist in the search results to open the application. If SupportAssist is not listed in the search results, it means that the application is not installed on your computer. For more information about how to download and install SupportAssist, see the SupportAssist for Home PCs page.
  3. Your product model is displayed on the main screen of the application.

Windows 8 (8.1)

  1. Swipe in from the right edge of the screen or move the cursor to the upper right corner of the screen until the Charms Bar appears.
  2. Select Search.
  3. In the Search Box, type SupportAssist.
  4. Touch or click SupportAssist in the search results to open the application. If SupportAssist is not listed in the search results, it means that the application is not installed on your computer. For more information about how to download and install SupportAssist, see the SupportAssist for Home PCs page.
  5. Your product model is displayed on the main screen of the application.

Back to top


Method 3: Using the Windows System Information utility

Windows System Information (also known as msinfo32) shows a computer summary menu with details such as your model, manufacturer, and operating system version.

To find your product model using Windows System Information

NOTE: Press the Windows Logo + Break keys to quickly open the Windows System Information window. On some laptops, you press Windows Logo + Fn + Break, when your laptop keyboard does not have the Break key, and then follow the instructions below.

Windows 11 or Windows 10

  1. In the Search Box, type System.
  2. In the list of search results, under settings, select System.
  3. Look for Model: in the System section.

Windows 8 (8.1)

  1. Swipe in from the right edge of the screen, and then tap Search (If you are using a mouse, hover over the lower-right corner of the screen, move the mouse pointer up, and then click Search).
  2. Type msinfo32 in the search box.
  3. In the list of search results, tap or click msinfo32 to open the System Information window.
  4. Look for Model: in the System section.

Back to top


Method 4: Using your Dell computer's BIOS or UEFI

BIOS stands for basic input or output system. When you turn on your computer, the BIOS or UEFI firmware runs first to check that your hardware is working and then allows the operating system to start. You can access the BIOS to find basic hardware information about your Dell computer and its hardware without using the operating system.

To find your product model number in the system BIOS or UEFI.

  1. Turn on your computer.
  2. At the Dell logo screen, tap the F2 key several times to access the BIOS or UEFI. If the operating system starts, reboot the computer and try again.
  3. On the BIOS or UEFI menu, find the product model in the menu title or listed under System Name.

Back to top

Additional Information

Recommended Articles

Here are some recommended articles related to this topic that might be of interest to you.


Out of Warranty support Out of warranty? No problem. Browse to the Dell.com/support website and enter your Dell Service Tag and view our offers.

NOTE: Offers are only available for US, Canada, UK, France, Germany, China, and Japan personal computer customers. Server and Storage not applicable.

Article Properties


Affected Product

Chromebox, Alienware, Inspiron, Legacy Desktop Models, OptiPlex, Vostro, XPS, G Series, Chromebook, G Series, Alienware, Inspiron, Latitude, Vostro, XPS, Legacy Laptop Models, Fixed Workstations, Mobile Workstations

Last Published Date

09 Jan 2024

Version

13

Article Type

Solution