Baza wiedzy

Dell Endpoint Security Suite Enterprise System Requirements


This article covers the system requirements for installing Dell Endpoint Security Suite Enterprise.


Affected Products:

Dell Endpoint Security Suite Enterprise

Affected Platforms:

Windows
Mac


Network Requirements:

Network requirements vary based on the version of Dell Security Management Server (formerly Dell Data Protection Server). Click on the appropriate version for more information.

Note: For assistance on locating the server version, reference How to Identify the Version of Dell Security Management Server.

Outbound traffic must be opened to the following destinations for any environment using Dell Endpoint Security Suite Enterprise. Alternatively, an existing HTTP/HTTPS proxy server may be used in place of direct connectivity through the firewall. Destinations are based on the region selected during initial service configuration of Advanced Threat Protection.

America Destinations Europe Destinations Asia Destinations Protocol Port
login.cylance.com login-euc1.cylance.com login-au.cylance.com HTTPS TCP 443
data.cylance.com data-euc1.cylance.com data-au.cylance.com HTTPS TCP 443
protect.cylance.com protect-euc1.cylance.com protect-au.cylance.com HTTPS TCP 443
update.cylance.com update-euc1.cylance.com update-au.cylance.com HTTPS TCP 443
api.cylance.com api-euc1.cylance.com api-au.cylance.com HTTPS TCP 443
protect-api.cylance.com protect-api-euc1.cylance.com protect-api-au.cylance.com HTTPS TCP 443
download.cylance.com download.cylance.com download.cylance.com HTTPS TCP 443
sha2act.credant.com sha2act.credant.com sha2act.credant.com HTTPS TCP 443
cloud.dell.com cloud.dell.com cloud.dell.com HTTPS TCP 443
Note:
  • Destinations are hosted by Amazon Web Services through dynamic IPs. The IPs are not static and are subject to change without notice.
  • Alternatively *.cylance.com, *.dell.com, & *.credant.com may be used.

Outbound traffic must be opened to the following destinations for any environment using Dell Endpoint Security Suite Enterprise. Alternatively, an existing HTTP/HTTPS proxy server may be used in place of direct connectivity through the firewall. Destinations are based on the region selected during initial service configuration of Advanced Threat Protection.

America Destinations Europe Destinations Asia Destinations Protocol Port
login.cylance.com login-euc1.cylance.com login-au.cylance.com HTTPS TCP 443
data.cylance.com data-euc1.cylance.com data-au.cylance.com HTTPS TCP 443
protect.cylance.com protect-euc1.cylance.com protect-au.cylance.com HTTPS TCP 443
update.cylance.com update-euc1.cylance.com update-au.cylance.com HTTPS TCP 443
api.cylance.com api.cylance.com api.cylance.com HTTPS TCP 443
protect-api.cylance.com protect-api-euc1.cylance.com protect-api-au.cylance.com HTTPS TCP 443
download.cylance.com download.cylance.com download.cylance.com HTTPS TCP 443
act.credant.com act.credant.com act.credant.com HTTPS TCP 443
cloud.dell.com cloud.dell.com cloud.dell.com HTTPS TCP 443
Note:
  • Destinations are hosted by Amazon Web Services through dynamic IPs. The IPs are not static and are subject to change without notice.
  • Alternatively *.cylance.com, *.dell.com, & *.credant.com may be used.

Outbound traffic must be opened to the following destinations for any environment using Dell Endpoint Security Suite Enterprise. Alternatively, an existing HTTP/HTTPS proxy server may be used in place of direct connectivity through the firewall.

America Destinations Protocol Port
login.cylance.com HTTPS TCP 443
data.cylance.com HTTPS TCP 443
protect.cylance.com HTTPS TCP 443
update.cylance.com HTTPS TCP 443
api.cylance.com HTTPS TCP 443
protect-api.cylance.com HTTPS TCP 443
download.cylance.com HTTPS TCP 443
act.credant.com HTTPS TCP 443
cloud.dell.com HTTPS TCP 443
Note:
  • Destinations are hosted by Amazon Web Services through dynamic IPs. The IPs are not static and are subject to change without notice.
  • Alternatively *.cylance.com, *.dell.com, & *.credant.com may be used.


Click on the appropriate operating system tab for specific platform requirements.

The Windows version of Dell Endpoint Security Suite Enterprise integrates Cylance’s Advanced Threat Protection client with Dell Encryption Enterprise (formally Dell Data Protection | Enterprise Edition Shield) security options:

  • File Folder Based Encryption
  • BitLocker Manager
  • Self-Encrypting Drive
  • External Media Encryption
  • Server Encryption

This article covers only the Advanced Threat Protection client requirements. For information on the encryption prerequisites please reference the documentation at www.dell.com/support/home.

General Requirements:

  • Local Administration rights for installation.
  • Dell Security Management Server version 9.2 or later.
  • Dell Endpoint Security Suite Enterprise license

Software Requirements:

Software requirements vary by version of Dell Endpoint Security Suite Enterprise for Windows. Click on the appropriate software version for more information.

Note: For assistance on locating the product version, reference How to Identify the Version of Dell Endpoint Security Enterprise.

Operating Systems (32 and 64 bit):

  • Windows 7 SPO-SP1, Enterprise, Professional, Ultimate
  • Windows 8 Enterprise, Pro
  • Windows 8.1 Update 0-1, Enterprise, Pro1
  • Windows 10 Education, Enterprise, Pro2
  • Windows Server 2008 R2 SP1: Standard Edition, Datacenter Edition, Enterprise Edition, Webserver Edition3
  • Windows Server 2012: Standard Edition, Essentials Edition, Datacenter Edition3
  • Windows Server 2012 R2: Standard Edition, Essentials Edition, Datacenter Edition3
  • Windows Server 2016: Standard Edition, Essentials Edition, Datacenter Edition3

1Windows 8.1 RT is not supported
2Supports versions 1511 (November Update/Threshold 2), 1607 (Anniversary Update / Redstone), and 1703(Creators Update / Redstone 2).
2Version 1709 (Fall Creators Update / Redstone 3) is not supported.
3Server Core (2008/2012/2016) and Minimal Server (2012) are not supported

Software Prerequisites:

  • Dell Client Security Framework (EMAgent.exe)
  • Visual C++ 2012 Update 4 or later Redistributable Package (x86 and x64)
  • Visual C++ 2015 Update 3 or later Redistributable Package (x86 and x64)
    • Visual C++ 2015 requires Windows Update KB29992626 if installed on Windows 7.
Note:
  • Dell Client Security Framework, Visual C++ 2012 Update 4 and C++ 2015 Update 3 are automatically installed when installing Dell Endpoint Security Suite Enterprise through the installation wizard.
  • Only use the version of Dell Client Security Framework that is packaged with Dell Endpoint Security Suite Enterprise. Failure to use the appropriate version may lead to product issues.
  • The full version of Microsoft .Net Framework 4.5.2 (or later)

Other Requirements:

  • Local Administration rights.
  • Dell Security Management Server version 9.2 or later.
  • Dell Endpoint Security Suite Enterprise license.

Operating Systems (32 and 64 bit):

  • Windows 7 SPO-SP1, Enterprise, Professional, Ultimate
  • Windows 8 Enterprise, Pro
  • Windows 8.1 Update 0-1, Enterprise, Pro1
  • Windows 10 Education, Enterprise, Pro2
  • Windows Server 2008 R2 SP1: Standard Edition, Datacenter Edition, Enterprise Edition, Webserver Edition3
  • Windows Server 2012: Standard Edition, Essentials Edition, Datacenter Edition3
  • Windows Server 2012 R2: Standard Edition, Essentials Edition, Datacenter Edition3
  • Windows Server 2016: Standard Edition, Essentials Edition, Datacenter Edition3

1Windows 8.1 RT is not supported
2Supports versions 1511 (November Update/Threshold 2) and 1607 (Anniversary Update / Redstone).
2Versions 1703 (Creators Update / Redstone 2) and 1709 (Fall Creators Update / Redstone 3) are not supported.
3Server Core (2008/2012/2016) and Minimal Server (2012) are not supported

Software Prerequisites:

  • Dell Client Security Framework (EMAgent.exe)
  • Visual C++ 2012 Update 4 or later Redistributable Package (x86 and x64)
Note:
  • Dell Client Security Framework and Visual C++ 2012 Update 4 are automatically installed when installing Dell Endpoint Security Suite Enterprise through the installation wizard.
  • Failure to use the associated Dell Client Security Framework version that is part of the Dell Endpoint Security Suite Enterprise will prevent product functionality.
  • The full version of Microsoft .Net Framework 4.5.2 (or later)

Other Requirements:

  • Local Administration rights.
  • Dell Security Management Server version 9.2 or later.
  • Dell Endpoint Security Suite Enterprise license.

Operating Systems (32 and 64 bit):

  • Windows 7 SPO-SP1, Enterprise, Professional, Ultimate
  • Windows 8 Enterprise, Pro
  • Windows 8.1 Update 0-1, Enterprise, Pro1
  • Windows 10 Education, Enterprise, Pro2
  • Windows Server 2008 R2 SP1: Standard Edition, Datacenter Edition, Enterprise Edition, Webserver Edition3
  • Windows Server 2012: Standard Edition, Essentials Edition, Datacenter Edition3
  • Windows Server 2012 R2: Standard Edition, Essentials Edition, Datacenter Edition3

1Windows 8.1 RT is not supported
2Supports versions 1511 (November Update/Threshold 2) and 1607 (Anniversary Update / Redstone).
2Versions 1703 (Creators Update / Redstone 2) and 1709 (Fall Creators Update / Redstone 3) are not supported.
3Server Core (2008/2012) and Minimal Server (2012) are not supported

Software Prerequisites:

  • Dell Client Security Framework (EMAgent.exe)
  • Visual C++ 2012 Update 4 or later Redistributable Package (x86 and x64)
Note:
  • Dell Client Security Framework and Visual C++ 2012 Update 4 are automatically installed when installing Dell Endpoint Security Suite Enterprise through the installation wizard.
  • Only use the version of Dell Client Security Framework that is packaged with Dell Endpoint Security Suite Enterprise. Failure to use the appropriate version may lead to product issues.
  • The full version of Microsoft .Net Framework 4.5.2 (or later)

Other Requirements:

  • Local Administration rights.
  • Dell Security Management Server version 9.2 or later.
  • Dell Endpoint Security Suite Enterprise license.

Operating Systems (32 and 64 bit):

  • Windows 7 SPO-SP1, Enterprise, Professional, Ultimate
  • Windows 8 Enterprise, Pro
  • Windows 8.1 Update 0-1, Enterprise, Pro1
  • Windows 10 Education, Enterprise, Pro2
  • Windows Server 2008 R2 SP1: Standard Edition, Datacenter Edition, Enterprise Edition, Webserver Edition3
  • Windows Server 2012: Standard Edition, Essentials Edition, Datacenter Edition3
  • Windows Server 2012 R2: Standard Edition, Essentials Edition, Datacenter Edition3

1Windows 8.1 RT is not supported
2Supports version 1511 (November Update/Threshold 2)
2Versions 1607 (Anniversary Update / Redstone), 1703 (Creators Update / Redstone 2) and 1709 (Fall Creators Update / Redstone 3) are not supported.
3Server Core (2008/2012) and Minimal Server (2012) are not supported

Software Prerequisites:

  • Dell Client Security Framework (EMAgent.exe).
  • Visual C++ 2012 Update 4 or later Redistributable Package (x86 and x64)
Note:
  • Dell Client Security Framework and Visual C++ 2012 Update 4 are automatically installed when installing Dell Endpoint Security Suite Enterprise through the installation wizard.
  • Only use the version of Dell Client Security Framework that is packaged with Dell Endpoint Security Suite Enterprise. Failure to use the appropriate version may lead to product issues.
  • The full version of Microsoft .Net Framework 4.5.2 (or later)

Other Requirements:

  • Local Administration rights.
  • Dell Security Management Server version 9.2 or later.
  • Dell Endpoint Security Suite Enterprise license.

Operating Systems (32 and 64 bit):

  • Windows 7 SPO-SP1, Enterprise, Professional, Ultimate
  • Windows 8 Enterprise, Pro
  • Windows 8.1 Update 0-1, Enterprise, Pro1
  • Windows 10 Education, Enterprise, Pro2

1Windows 8.1 RT is not supported
2Supports build 1511 (November Update)
2Build 1607 (Anniversary Update / Redstone), Windows 10 build 1703 (Creators Update / Redstone 2), and build 1709 (Fall Creators Update / Redstone 3) are not supported.

Software Prerequisites:

  • Dell Client Security Framework (EMAgent.exe)
  • Visual C++ 2012 Update 4 or later Redistributable Package (x86 and x64)
Note:
  • Dell Client Security Framework and C++ 2012 Update 4 are automatically installed when installing Dell Endpoint Security Suite Enterprise through the installation wizard.
  • Only use the version of Dell Client Security Framework that is packaged with Dell Endpoint Security Suite Enterprise. Failure to use the appropriate version may lead to product issues.
  • The full version of Microsoft .Net Framework 4.0 (or later)

Other Requirements:

  • Local Administration rights.
  • Dell Security Management Server version 9.2 or later.
  • Dell Endpoint Security Suite Enterprise license.

The Mac version of Dell Endpoint Security Suite Enterprise integrates Cylance’s Advanced Threat Protection client with Dell Encryption Enterprise for Mac.

This article covers only the Advanced Threat Protection client requirements. Reference Dell Encryption Enterprise for Mac System Requirements for information on the encryption client.

General Requirements:

  • Local Administration rights for installation.
  • Dell Security Management Server (formally Dell Data Protection Server) version 9.5 or later.
  • Dell Endpoint Security Suite Enterprise license
Note: Dell Data Protection Server version 9.4.1 can be patched to support Dell Endpoint Security Suite Enterprise for Mac. The patch can be obtained through Dell Data Protection ProSupport at: 877.459.7304 Ext. 4310039 (US). For customers outside the US refer to the International Contact numbers list

Minimum Hardware Requirements:

  • 500MB free disk space
  • 2GB RAM
  • 10/10/1000 or Wi-FI network card

Software Requirements:

Software requirements vary by version of Dell Endpoint Security Suite Enterprise for Mac. Click on the appropriate software version for more information.

Note: For more information on versioning reference, How to Identify the Version of Dell Endpoint Security Suite Enterprise

Operating Systems (64 bit):

  • macOS High Sierra 10.13.0 to 10.13.1
  • macOS Sierra 10.12.3 to 10.12.6
  • Mac OS X El Capitan 10.11.6
  • Mac OS X Yosemite 10.10.5
Note: Kernel Extensions must be approved on macOS High Sierra for product functionality. Reference How to Allow Dell Data Security Kernel Extensions on macOS for more information.

Operating Systems (64 bit):

  • macOS Sierra 10.12.3 to 10.12.6
  • Mac OS X El Capitan 10.11.6
  • Mac OS X Yosemite 10.10.5

Operating Systems (64 bit):

  • macOS Sierra 10.12.3
  • Mac OS X El Capitan 10.11.6
  • Mac OS X Yosemite 10.10.5
  • Mac OS X Mavericks 10.9.5

Operating Systems (64 bit):

  • Mac OS X El Capitan 10.11.6
  • Mac OS X Yosemite 10.10.5
  • Mac OS X Mavericks 10.9.5

For additional support, US based customer can call Dell Data Security ProSupport at: 877.459.7304 Ext. 4310039 or you may also contact us via the Chat Portal. For support outside the US, reference ProSupport’s International Contact Numbers list. Visit the Dell Security Community Forum to get insights from other community members and additional resources to help you manage your environment.


Identyfikator artykułu: SLN303898

Data ostatniej modyfikacji: 12/01/2017 09:38 AM


Oceń ten artykuł

Trafne
Przydatne
Łatwe do zrozumienia
Czy ten artykuł był przydatny?
Tak Nie
Wyślij nam swoją opinię
Komentarze nie mogą zawierać znaków specjalnych: <>()\
Niestety, nasz system przekazywania opinii jest obecnie niedostępny. Spróbuj ponownie później.

Dziękujemy za uwagi.