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USB Mouse, Keyboard and, Other Devices are Non-Responsive After Windows 10 Update KB4074588

Summary: Solutions for USB mouse, keyboard, and other devices not responding after the Windows 10 Update (KB4074588).

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Article Content


Symptoms

No symptom information is available.

Cause

No cause information is available.

Resolution

USB Devices Non-Responsive

Desktops and Notebooks running Windows 10 may experience Keyboard and Mouse lockups with the recent Windows 10 update: KB4074588

  • Microsoft published KB4090914 on March 5, 2018 to correct the issue, and Windows Update (WU) will push the update automatically to the system.
  • This should resolve the issues for unresponsive USB devices automatically.
  • KB4074588 stays active in WU as cumulative security and quality update for systems running RS3 (1709).

On systems affected by KB4074588:

  • Attempt to boot Windows 10 to Safe Mode with Networking.
    Note: Requires Ethernet connection as Wi-Fi will be disabled in Safe Mode.

    Microsoft Update Catalog
  • Open a web browser and navigate to https://www.catalog.update.microsoft.com This hyperlink is taking you to a website outside of Dell Technologies.
  • Search for KB4090914
    • 2018-03 Update for Windows 10 Version 1709 for ARM64-based Systems (KB4090914)
    • 2018-02 Update for Windows 10 Version 1709 for x86-based Systems (KB4090914)
    • 2018-02 Update for Windows Server 2016 (1709) for x64-based Systems (KB4090914)
    • 2018-02 Update for Windows 10 Version 1709 for x64-based Systems (KB4090914)
  • Download the version that matches the Operating System (OS) on the system.
  • Install and reboot.

If the system cannot boot to safe mode with networking, follow the below steps to remove KB4074588 (RollupFix~31bf3856ad364e35~amd64~~16299.248.1.17):


Solution Options

You have three options that can correct this behavior when using the Windows Recovery Environment:

  • Option 1) Use System Restore to go back to before the KB installed
  • Option 2) Manually remove the update using Command Prompt
  • Option 3) Windows Refresh or Operating System Re-Install (OSRI)

See below for Solution Details on how to apply each of these solutions.

Note: After applying any of these solutions, it is recommended you prevent the update from reinstalling.

Accessing Windows Recovery Environment

Steps to access the Windows Recovery Environment for all Dell Windows 8 and 10 systems:

  1. Power on the system and when you see Dell logo power off system.
  2. Repeat three times and on the fourth boot up you will be in recovery mode.
Note: Alternatively you can boot to a DVD drive and the Dell recovery media you can boot to that to access to the recovery mode.

Solution Details

Option 1: Use System Restore to go back to before the KB is installed
  1. Select Troubleshoot -> Advanced Option -> System Restore.
  2. Select any Restore Point before this KB was installed or February 13, 2018. If System Restore is turned off, or no restore point is available, go to the manual removal.
  3. If a restore point is found, select the restore point and start the system restore - this takes as long as Windows Reset or OSRI.

Option 2: Manually remove the update using Command Prompt

Note: If BitLocker is enabled, you may be prompted to enter the Recovery Key. This requires access to a second device to retrieve the key from their Microsoft Account -> https://account.microsoft.com/devices/recoverykey This hyperlink is taking you to a website outside of Dell Technologies..
 
Note: In the example below, the Windows drive is D:\. If this is not successful, check to see if you drive is C:\.
 
  1. Select Troubleshoot -> Advanced Option -> Command Prompt.
  2. On the command, to get a list of installed Windows Updates.
  3. dism /image:D:\ /Get-Packages /format:table (Figure 1)
    Windows Command Line
    Figure 1
     
  4. Verify that the list continues Package_for_RollupFix~31bf3856ad364e35~amd64~~16299.248.1.17
  5. Remove the package:
    dism /image:D:\ /Remove-Package /PackageName:Package_for_RollupFix~31bf3856ad364e35~amd64~~16299.248.1.17
  6. Restart the system after DISM is finished.
  7. The system boots back to the Windows login screen. You can now log in and work.
 

Option 3: Windows Refresh or OSRI

If the update cannot be removed or the issue persists, refresh Windows (Windows 10 is the same process as Windows 8).
Factory Reset, Restore, or Reinstall Microsoft Windows on a Dell computer


Block the Update from Reinstalling

  1. Download the Show or Hide Updates This hyperlink is taking you to a website outside of Dell Technologies. troubleshooter package (you must Right Click and "Save as," then select "Keep").
  2. Save it to the desktop.
  3. Navigate to the Windows desktop and double-click wushowhide.diagcab.
  4. Click Next and wait for the application to display the list of installed updates.
  5. Click Hide Updates (Figure 2).
    Microsoft Hide Updates
    Figure 2
     
  6. Check KB4074588.
  7. Click Next and follow the prompts.
  8. Restart the system and test keyboard and mouse functionality to log back into Windows.

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Article Properties


Affected Product

Alienware, Inspiron, OptiPlex, Vostro, XPS, G Series, G Series, Alienware, Inspiron, Latitude, Vostro, XPS, Fixed Workstations, Mobile Workstations

Last Published Date

05 Apr 2024

Version

9

Article Type

Solution