跳至主要內容
  • 簡單快速地下訂單
  • 檢視訂單及追蹤商品運送狀態
  • 建立並存取您的產品清單
  • 使用「公司管理」來管理您的 Dell EMC 網站、產品和產品層級連絡人。
部分文章編號可能已變更。如果這不是您要找的文章,請嘗試搜尋所有文章。搜尋文章

Data Domain: Too frequent update of Attr BTree causes File System Panic

摘要: Frequent update of Attr BTree may cause file system PANICs, with signatures like "PANIC: ddr/dm/dmbt_iface.c: dmbt_find_intr_key_new: 10994: (i + 1) >= count."

本文可能採用自動翻譯。如果您對翻譯品質有任何寶貴意見,請使用此頁面底部的表單告訴我們,謝謝。

文章內容


症狀

Filesystem Panic with the following PANIC threads (different version may show a bit different):      
  PANIC : ddr/dm/dmbt_iface.c: dmbt_find_intr_key_new: 10994: (i + 1) >= count
Or
  PANIC: ddr/dm/dmbt_intern_fast.c: dmbt_bsearch_page: 157: Unsupported page type reported
Or
  PANIC: ddr/dm/dmbt_iface.c: dmbt_find_intr_key_new: 11664: (i + 1) >= count
The issue is observed in several DDOS releases so far.
  • It was first identified in DDOS 6.1.1.5.
  • Over time, DDOS versions earlier than 6.2.1.40 and 7.2.0.50 were also found affected by this issue.

原因

Replication triggers Attr BTree so frequently that file system may eventually PANIC when accessing the attribute metadata associated to the files in the MTree.

A similar PANIC may also happen if the Physical Capacity Reporting (PCR) feature is used or frequently used.

解析度

If you suspect the Data Domain has experienced this issue, do the following:      The issue develops over time. Access to the attribute or PCR BTree for a given MTree is repeatedly made by normal system workloads.
On an affected DDOS release, the issue gets worse over time.
System performance may be affected even before file system PANICs occur.
Once a file system PANICs due to this issue, depending on where in the BTree the issue is, there may be subsequent file system PANICs occurring at any time (even back to back, keeping the file system down).

The fundamental issue causing the deterioration of attribute or PCR BTrees is resolved in the following DDOS releases:
  • DDOS 6.2.1.40 or later releases in DDOS 6.2.1.x
  • DDOS 7.2.0.50 or later releases in DDOS 7.2.x
  • DDOS 7.3.0.10 or later releases in DDOS 7.3.x
  • DDOS 7.4.0.0 and all later releases
Upgrading to a fixed release does not resolve the existing deterioration of the affected attribute or PCR BTree.
It should avoid it getting worse, but cannot be ruled out in certain circumstances, and system slowness may occur as a result of existing BTree deterioration, and file system PANICs may still occur.

To resolve the issue, it is necessary to contact Dell technical support for running low-level commands (with downtime required) so that the attributes, or PCR BTrees, are removed (they are re-created automatically over time once the file system process is up again). Hence the recommendation is to contact Support for resolving the existing BTree damage and immediately upgrade to a fixed release.
See Data Domain: DD OS Software Versions for guidance about the releases required. Login to Dell Support as a registered user is required to view article.

文章屬性


受影響的產品

Data Domain

上次發佈日期

11 12月 2023

版本

18

文章類型

Solution