tanboi_3
4 Tellurium

VXRAIL バージョンの違うノードの増設について

ソリューションへジャンプ

いつもお世話になっております。
現在のデフォルトのVXRAILのOSバージョンはv4.7.410だと思いますが、
このバージョンより古いv4.7.210や4.7.300 の既存ノードに4.7.410のノードを増設する場合、
まずは既存ノードすべてを4.7.410にバージョンアップしてからノード増設、という流れになりますでしょうか?
それとも、ノード間で違うバーションの混在でも増設、運用可能でしょうか?

以上、よろしくお願いします。

0 件の賞賛
3 解決策

受理された解決策
kwmt
4 Tellurium

Re: VXRAIL バージョンの違うノードの増設について

ソリューションへジャンプ

VxRail のノード追加は基本的に親となる「既存クラスタ」のバージョンより「新規ノードのバージョンが新しい」場合は追加不可となっています(GAバージョンと出荷バージョンが近い場合に例外があるかもです)。

既存クラスタバージョンに対して追加がサポートされるノードのバージョンは
Node Addition Matrix にまとまっているのと、
https://dl.dell.com/content/docu92203_VxRail_Appliance_Node_Addition_Matrix.pdf

Solve のノード追加の手順書や対象バージョンのリリースノートにもその他の注意書きがあるので併せて確認するのが推奨です。

通常は既存のクラスタをバージョンアップ後に、追加のノードを組み込む事が推奨となります。
※ RASA での追加ノードのダウングレードは Firmwear の関係でサポートされない事があるはずです。

元の投稿で解決策を見る

naoyuki_kaneda
4 Beryllium

Re: VXRAIL バージョンの違うノードの増設について

ソリューションへジャンプ

すでにkwmtさんからも回答をいただいている通り、既存ClusterのUpgradeして、出荷Versionに合わせるのがセオリーとなります。

RASRによる出荷Nodeのダウングレードは基本的に非サポートとなり、動作が保証されません。最悪の場合Nodeが起動しないなどの状態になることもありえます。

どうしてもという場合についてはDell EMC担当営業経由でダウングレードの特別承認可否についてRPQでご相談いただくことになります。しかしながら承認されない場合もあります。(Release 時にCPU世代に差異のあるVersion間のDowngradeなど)

したがって、やはり既存ClusterのUpgradeを実施いただくのが推奨となります。

Upgradeに関してはDell EMCの無償Upgradeサービスも利用可能ですが、日本語対応エンジニアの場合は一か月待ちになることもありますので、お早めに調整されることをお勧めします。(英語対応可能な場合はもっと早くなることもあります)

 

元の投稿で解決策を見る

kwmt
4 Tellurium

Re: VXRAIL バージョンの違うノードの増設について

ソリューションへジャンプ

VxRail からインターネットにつないでダイレクトにパッチをダウンロードする場合は、アップデート可能な最新版が降ってきます。

個別の指定バージョンに更新したい場合は、サポートサイトから任意のバージョンのアップデート用のバンドルパッケージをダウンロードして、ファイルを vCenter の VxRail Manager UI に取り込めば可能です。

元の投稿で解決策を見る

5 返答(返信)
kwmt
4 Tellurium

Re: VXRAIL バージョンの違うノードの増設について

ソリューションへジャンプ

VxRail のノード追加は基本的に親となる「既存クラスタ」のバージョンより「新規ノードのバージョンが新しい」場合は追加不可となっています(GAバージョンと出荷バージョンが近い場合に例外があるかもです)。

既存クラスタバージョンに対して追加がサポートされるノードのバージョンは
Node Addition Matrix にまとまっているのと、
https://dl.dell.com/content/docu92203_VxRail_Appliance_Node_Addition_Matrix.pdf

Solve のノード追加の手順書や対象バージョンのリリースノートにもその他の注意書きがあるので併せて確認するのが推奨です。

通常は既存のクラスタをバージョンアップ後に、追加のノードを組み込む事が推奨となります。
※ RASA での追加ノードのダウングレードは Firmwear の関係でサポートされない事があるはずです。

元の投稿で解決策を見る

tanboi_3
4 Tellurium

Re: VXRAIL バージョンの違うノードの増設について

ソリューションへジャンプ

kwmtさん

ご回答ありがとうございます。あとコンパチガイド大変助かりました。

すいません、追加でご質問させてください。

既存のクラスタをバージョンアップするとき、どのバージョンにするかを選ぶことができるのでしょうか?

それとも現状の最も新しいバージョンに自動的に設定されてバージョンアップされるのでしょうか?

以上、よろしくお願いします。

0 件の賞賛
kwmt
4 Tellurium

Re: VXRAIL バージョンの違うノードの増設について

ソリューションへジャンプ

VxRail からインターネットにつないでダイレクトにパッチをダウンロードする場合は、アップデート可能な最新版が降ってきます。

個別の指定バージョンに更新したい場合は、サポートサイトから任意のバージョンのアップデート用のバンドルパッケージをダウンロードして、ファイルを vCenter の VxRail Manager UI に取り込めば可能です。

元の投稿で解決策を見る

naoyuki_kaneda
4 Beryllium

Re: VXRAIL バージョンの違うノードの増設について

ソリューションへジャンプ

すでにkwmtさんからも回答をいただいている通り、既存ClusterのUpgradeして、出荷Versionに合わせるのがセオリーとなります。

RASRによる出荷Nodeのダウングレードは基本的に非サポートとなり、動作が保証されません。最悪の場合Nodeが起動しないなどの状態になることもありえます。

どうしてもという場合についてはDell EMC担当営業経由でダウングレードの特別承認可否についてRPQでご相談いただくことになります。しかしながら承認されない場合もあります。(Release 時にCPU世代に差異のあるVersion間のDowngradeなど)

したがって、やはり既存ClusterのUpgradeを実施いただくのが推奨となります。

Upgradeに関してはDell EMCの無償Upgradeサービスも利用可能ですが、日本語対応エンジニアの場合は一か月待ちになることもありますので、お早めに調整されることをお勧めします。(英語対応可能な場合はもっと早くなることもあります)

 

元の投稿で解決策を見る

tanboi_3
4 Tellurium

Re: VXRAIL バージョンの違うノードの増設について

ソリューションへジャンプ

kwmtさん

ご回答ありがとうございます。

個別の指定バージョンに更新することも可能とのことで安心しました。

 

naoyuki_kanedaさん

ご回答ありがとうございます。

ダウングレードはいろいろと危険そうですので、推奨どおりまずは既存ノードをアップグレードし、増設ノードのバージョンに合わせたうえで増設しようと思います。

0 件の賞賛