VxRail:PTAgentアップグレードの失敗、ESXi エラー「Can not delete non-empty group: dellptagent」(000516314)

モデレーター
モデレーター

VxRail:PTAgentアップグレードの失敗、ESXi エラー「Can not delete non-empty group: dellptagent」(000516314)

プライマリ製品:VxRail 460および470ノード

製品:VxRail 460および470ノード、VxRail Eシリーズ ノード、VxRail Pシリーズ ノード、VxRail Sシリーズ ノード、VxRail Vシリーズ ノード、VxRailソフトウェア4.0、VxRailソフトウェア4.5

バージョン:6
記事タイプ:不具合修正
対象読者:レベル30 = お客様
最終発行日:2018年8月16日木曜日08:45:54(GMT)

サマリー:

問題:
VxRailのアップグレード プロセスは、古いバージョンの1.4以下から新しい1.6以上にPTAgentをアップグレードするときに失敗します。

エラー メッセージ
[LiveInstallationError] Error in running ['/etc/init.d/DellPTAgent', 'start', 'upgrade']: Return code: 1 Output: ERROR: ld.so: object '/lib/libMallocArenaFix.so' from LD_PRELOAD cannot be preloaded: ignored. ERROR: ld.so: object '/lib/libMallocArenaFix.so' from LD_PRELOAD cannot be preloaded: ignored. ERROR: ld.so: object '/lib/libMallocArenaFix.so' from LD_PRELOAD cannot be preloaded: ignored. Errors: Can not delete non-empty group: dellptagent It is not safe to continue. Please reboot the host immediately to discard the unfinished update. Please refer to the log file for more details.

Dell ptAgent upgrade failed on target: <hostname> failed due to Bad script return code:1

原因:
PTAgentの以前のバージョン(1.6以下)にはプロセス信号の処理に問題があったため、PTAgentを削除するにはESXiに再起動を求められます。ESXiはどのような信号が送信されるか、どのメソッドがプロセスを強制終了するために試みられるかに関係なく停止できません。ESXi siの再起動では、アップグレードを続行できるように、失効したプロセスを強制終了することが必要です。

PTAgent 1.6(以上)では、この問題は修正されていますが、1.4から1.6へのアップグレードでは、問題が発生した後、完了するには人間の介入が必要です。

影響を受けるVxRailバージョン(Dellプラットフォームのみ):
・ 4.0.x:VxRail 4.0.310以下
・ 4.5.x:VxRail 4.5.101以下

解決策:
この問題は最近のVxRailリリースでは修正されていますが、以前のVxRailリリースからのアップグレードする場合には大きな影響があります。以下のVxRailリリースに含まれているPTAgent 1.7-4 にアップグレードするには、Dell EMCテクニカル サポートに問い合わせることを強くお勧めします。
・ vSphere 6.0を維持するお客様ではVxRail 4.0.500
・ vSphere 6.5を選択するお客様ではVxRail 4.5.211以上
PTAgentアップグレードの失敗が発生した場合の手動回避策
・ メンテナンス モードに切り替え、エラー メッセージに記載されているホストを再起動します
・ ホストが使用可能になり、vCenterに適切な状態が表示されるまで待ち、VxRail Managerの[再試行]ボタンをクリックしてアップグレードを再試行します。

プライマリ製品:
VxRail 460および470ノード

製品:
VxRail 460および470ノード、VxRail Eシリーズ ノード、VxRail Pシリーズ ノード、VxRail Sシリーズ ノード、VxRail Vシリーズ ノード、VxRailソフトウェア4.0、VxRail ソフトウェア4.5

バージョン履歴
改訂番号
1/1
最終更新:
‎06-24-2019 11:31 AM
更新者:
 
寄稿者: