Greedy-Wolf
2 Iron

Networker 8.0无法使用VADP对VMware 5.5的虚拟机进行备份

客户将所有的VMware 5.0的虚拟机升级为5.5了。在进行VADP方式(镜像级)备份的时候任务无法进行下去系统出现hang住。

处理及问题过程如下:

1、客户更换为新的vcenter5.5后。  发起备份后,新旧备份服务器都无法备份vadp虚机,出现hang住,备份既不报错也不完成,处理到晚上依然无法排错;临时调整客户生产虚机的备份方式为文件方式,旧 7版本Networker弃用,全部采用新8版本新备份服务器备份。客户备份生产A组66台虚机,由全部vadp方式备份,改为80%文件备份,20%vADP备份。

2、文件备份方式正常,  排查vadp备份方式错误原因,初步怀疑是vcenter名字问题。

3、由于虚机备份就是hang住,通过-Debug模式,排错备份log日志,初步确认为需要备份的虚机的vmnet无法识别,无法被备份服务器识别出来。

VADP: VixMntApi - WARNING: ERROR: Error reading from mntApi304282029430508646\ControlSet001\Services\vmxnet - 2

VADP: VixMntApi Error 2 getting vmxnet information ,assuming vmxnet is not installed

汇报给VMware800后,给出结果是需要更改网卡类型。

4、更改2台虚机的vmnet网卡类型后,继续测试备份,网卡报错在log中不再出现报错;出现如下报错 VADP: VixMntApi Error reading element value from key mntApi304282029430508646\\elements

不知道有没有人遇到过同样的问题,请解决方法。

标签 (1)
0 项奖励
6 条回复6
Highlighted
Fenglin1
4 Beryllium

Re: Networker 8.0无法使用VADP对VMware 5.5的虚拟机进行备份

Greedy你好,

先不管说网络配置是不是都好的,NW在8.0版本首先已经不被EMC支持了,最少也要8.1.1,而且根据Networker Software Compatibility手册中的描述,

VADP: Image protection via the NetWorker 8.1+ for NTFS & non-NTFS File level protection via NetWorker 7.6 SP2+ and Client Proxy for NTFS only. (Supports NetWorker Client, Storage Node, and Server within a VM.)

VADP Support.png

所以,先升级NW试试吧。

https://support.emc.com/docu35302_NetWorker-Software-Compatibility-Guide-.pdf?language=en_US

Roger_Wu
4 Ruthenium

Re: Networker 8.0无法使用VADP对VMware 5.5的虚拟机进行备份

有条相似错误的KB: VMWare vSphere 5.5u3b causes VADP backups to slow down or fail

https://support.emc.com/kb/477350

内容也是建议升级到8.2 SP2以上版本,或者可以试下vSphere 5.5上启用SSLv3: https://kb.vmware.com/kb/2139396 。不过就像楼上说的,官方上是不再说明支持的了。

Greedy-Wolf
2 Iron

Re: Networker 8.0无法使用VADP对VMware 5.5的虚拟机进行备份

不好意思更正一下,Networker是8.2.2的,问题是客户的原厂服务已经没有了,所以找不到厂商的支持。

0 项奖励
Fenglin1
4 Beryllium

Re: Networker 8.0无法使用VADP对VMware 5.5的虚拟机进行备份

KB里建议的方法试过了吗?

0 项奖励
Greedy-Wolf
2 Iron

Re: Networker 8.0无法使用VADP对VMware 5.5的虚拟机进行备份

暂时还没有试过,主要是启动这个SSLv3可能需要和客户的安全管理部门沟通一下,客户有些东西是有规范手册的。不一定能让我启动。

0 项奖励
FeiLei
2 Bronze

Re: Networker 8.0无法使用VADP对VMware 5.5的虚拟机进行备份

根据你的描述,没法判断问题原因,我也经历过这样的排错,EMC通常解决不完善的地方都会给出升级建议,但介于客户的运维规范,往往不能够升级或者即刻升级。

对于Networker VADP的备份问题,你可以分以下几个步骤排查:

1,检查Networker中VM备份配置,比如虚拟机的备份模式,虚拟机的备份命令等。

2,备份时,你可以先去VMWARE CONSOLE中检查对应虚拟机的快照是否生成,若没有生成,查看VMWARE日志。

3,检查Proxy上挂载点上是否有虚拟机对应的数据文件,往往是这一步出现问题,这个时候,你需要在对应的VM配置里开启DEBUG,结合VMWARE的报错排查,最好联系VMWARE原厂一起查看。对于VADP的备份,Networker只是一个备份工作,至于快照、挂载等这些操作都是VMWARE主导,所以……

4,如果以上都完成了,但还是有问题,可以尝试删除一台VM的配置,重新扫描、配置备份。VM 5.0到5.5的改动也不算小,很难保证旧的备份信息不会对新的系统产生问题。

以上是我对VADP的排查经验,希望对你有帮助。