Highlighted
wait_shen
2 Bronze

CX300 write cache disabled.

hello,ECNer

手头上有一台CX300的老东西。现在发现DPE上亮琥珀色灯一个,其他部件无fault,write cache 无法enable。

我看了看日志,可能是由于:

Write cache enable pending, hardware problem:CMI chnnel 0 ffffff a0

CMI是什么东西?

标记 (4)
0 项奖励
12 条回复12
big_lei
3 Argentium

Re: CX300 write cache disabled.

CMI :Common Management Interface

0 项奖励
big_lei
3 Argentium

Re: CX300 write cache disabled.

感觉跟SPB SPSB 有关

0 项奖励
born_chen
4 Beryllium

Re: CX300 write cache disabled.

LZ确认电池没异常报错?

0 项奖励
wait_shen
2 Bronze

Re: CX300 write cache disabled.

电池状态灯正常。经常显示充放电

0 项奖励
lbseraph
2 Iron

Re: CX300 write cache disabled.

论坛的附件下了两三次都不完整,就先大概说一下思路供参考:

1. 如果你确认SPS、vault drive、系统盘笼电源等这些都没问题,可以尝试一下emc78278的方法,先把write cache归零,之后重新设置enable看看是否成功。

2. 如果上面的方法不行,看看能否抽个停机时间,把整个阵列power cycle一下看看。

0 项奖励
wait_shen
2 Bronze

Re: CX300 write cache disabled.

没有看到有vault disk的报错,sps b有多次冲放电的记录。

也已经接替重启了两个sp,依然没有什么效果。。

主要报错是write cache enable pending,hardware problem:CMI

这个是不是跟spb有一些关系呢?

发自我的 iPad

在 2014年1月19日,22:23,lbseraph <emc-community-network@emc.com> 写道:

ECN

CX300 write cache disabled.

从 中文支持论坛 中的 lbseraph 回复 - 查看完整讨论

论坛的附件下了两三次都不完整,就先大概说一下思路供参考:

1. 如果你确认SPS、vault drive、系统盘笼电源等这些都没问题,可以尝试一下emc78278的方法,先把write cache归零,之后重新设置enable看看是否成功。

2. 如果上面的方法不行,看看能否抽个停机时间,把整个阵列power cycle一下看看。

回复本电子邮件,或 前往ECN上的消息以回复本消息

在中文支持论坛中通过 电子邮件 或在 ECN开始新讨论

在这些流中关注 CX300 write cache disabled. : 收件箱

0 项奖励
lbseraph
2 Iron

Re: Re: CX300 write cache disabled.

我说的是整个阵列power cycle哈,需要拔电源线的,不是单单的reboot。另外,刚看了眼SPcollect的日志,可以看出没法enable应该是SP没法正确识别到对端SPS的状态。SPS充放电基本还是每6天多做一次,问题不大;如果是同一个SPS每天重复充放电(短时间内一直反复充放电)的话,就需要更换SPS了。还是先按照我上面说的两个方法先后试一下看看先吧(Power Cycle的时候最好在断电后把两个SP挨个重新插拔一下)。

## SPlogs output ##

A      01/18/14 08:54:20 SP A                  7c8 Write Cache Enable Pending. Hardware problem: CMI channel 0    ffffffff a0

## Ktracelogs output ##

A      01/18/14 08:54:20 CACHE            828b4da8 ca_ok_to_enable_cache() fails. Cache hardware not OK. Status: 0xa0

0 项奖励
Roger_Wu
5 Tungsten

Re: CX300 write cache disabled.

Fault还是有的:

DPE2 Bus 0 Enclosure 0       *FAULT*

  (Bus 0 Enclosure 0 : Faulted)

SP A State:                 Present

SP B State:                 Present

Bus 0 Enclosure 0 Fan A State: Present

Bus 0 Enclosure 0 Fan B State: Present

Bus 0 Enclosure 0 Power A State: Present

Bus 0 Enclosure 0 Power B State: Present

Bus 0 Enclosure 0 SPS A State: Present

Bus 0 Enclosure 0 SPS B State: Present

Bus 0 Enclosure 0 SPS A Cabling State: Valid

Bus 0 Enclosure 0 SPS B Cabling State: Valid

A       01/17/14 15:18:08 Bus0 Enc0            7409 Disk Processor Enclosure is faulted.

B       01/17/14 15:18:11                      2006 Able to read events from the Windows System log

B       01/17/14 15:18:11 NaviAgent               1 Navisphere Agent, version 6.26.0.2.19, has started

B       01/17/14 15:18:11                      2006 Able to read events from the Windows Application log

A       01/17/14 15:18:13 SP B                 743a Navisphere can no longer manage this SP. This does not impact server I/O to the storage system.

A       01/17/14 15:18:14                      720f The storage system has disabled write cache.

EMC已经停止支持CX300了,有渠道的话,那就换一下DPE,没渠道的话,迁移或者备份一下数据,采购新设备吧。

0 项奖励
lbseraph
2 Iron

Re: Re: CX300 write cache disabled.

LS没注意到LZ在18日下午4点多些(北京时间)挨个重启了SP吧?所以17日的日志参考的意义不大。换备件或换产品是后面的事了,先把非硬件更换能做的都做了之后还不行再考虑更换DPE之类吧。

0 项奖励