1 Copper

Aurora R5, Bricked Bios April 6 2020

I have had an Aurora R5 for a few years now and sad to say i never even got to use it much. As a developer i have my development environment on this computer and need to use it most of the time. But i bought the aurora to get an entry level into the whole VR thing and wanted to use it as a VR gaming machine. So Half-Life Alyx comes out i buy it and i get to play it once! The computer literally has not been used this much before hand first time setting it up was 3 weeks ago. Windows installed a bunch of udpates and dell installed a few updates as well. One of which being the bios. After that what happens now is when you go to power on the PC the alien head blinks amber lights 2 blinks then 1 blink.

The keyboard does not work unless i unplug it then plug it back in after a few seconds but i tried the whole bios recovery anyway, the mouse lights up so i presume it is working, the monitor will not get a signal.  

What i have tried so far:-

Bios recover as stated but without a keyboard it is impossible to tell if this is even working.

CMOS battery reseat, then replaced the cmos battery being sure to flash the cmos and leave 15 minutes before powering back on. 

Removed the ram, removed the graphics card. Unplugged every peripheral from the computer. Nothing is working to get the computer to boot. 

I tried switching around the rom recovery jumper, to no effect although i could not find any details on where this could be placed. 

This is a very poor first impression of an Alienware pc, and i always heard such good reviews. 

0 Kudos