Alienware Desktops

Last reply by 07-27-2022 Solved
Start a Discussion
2 Jasper
2 Jasper

Aurora R8, AWCC buggy

Your latest Alienware Command Center is buggy. It automatically updated via the Microsoft Store, when I opened your app it downloaded some things and installed them. Restarted my computer it says again additional components required. I click download it goes to a box saying the same thing but the only way to close is to click and isn't downloading anything. When I close that it shows an update available in the top right in green, I click that shows the same box. I download your file on your website for the latest Alienware cc and that will not do anything. It just shows a white box that locks up and the only way to close that is task manager. 

Replies (21)


The installation of the AWCC works fine.

The new version even identfied the issue I had with Fusion. Due to Hyper-V being installed it did not work before. Also solved.

Thanks & have a nice weekend!


Update-Issue Resolved after  installation of the AWCC

If still under warranty, click the "Get help now" icon on the right to start a live chat session.
Find your Service Tag

Latest Solutions
Top Contributor