Alienware Desktops

2 Bronze

VR Rift-S supper laggy for games - but working fine from unreal engine VR scenes.

Hi, I had a rift-S for more than a year. It was working great . But since a few weeks, its now supper laggy in games-only. Even oculus home is super laggy.
But when I run VR scenes from unreal engine (I do VR game dev), even very heavy games scenes, they are running fine and smooth. Running the same scene in standalone, like a game, make it run as laggy as any other game.

I did a repair of oculus app, like oculus suggested, it hasn't fixed anything. I tried with a different Rift-S headset, with new cable batteries etc... Same thing.

I haven't noticed complaints from other oculus users about the Rift-S past weeks.

I have an alienware - Nvidia RTX 2080.
For info, I have the old oculus home (with the fireplace). Is there a new version of the home or it hasn't changed?

Replies (3)
7 Thorium

What "Alienware" do you have? Also, what is the rest of your hardware-config.

My guess is that you have inadvertently installed some app, background process, or service that is cutting into your available processing power.

Or, maybe your USB ports are no longer running at full speed.

If you can't figure it out, you can always clean-install Windows-10 Pro 64bit from Microsoft's tool. Maybe to a spare SSD. Very minimal software loaded. I can provide tips if you need them. 


Registered Microsoft Partner and Apple Developer
- Like many of you, I can appreciate a good game-engine.
- I answer questions here, but I'm not a Dell employee.
- Consider giving posts you like a "thumbs-up"
- Posting models-numbers and software versions speeds trouble-shooting.
- Click "Accept as Solution" button on any post that answers your question best.

Hi, Thx for your help.

Its tricky to factory reset my PC, I have a lots of softwares and I'm using my pc remote work.

-Will I be able to reinstall aliens softwares?

When you say spare SSD, do you mean I could reset win10 on a new SSD while keeping my old setup as backup on the existing HD? If so I would really appreciate if you could point me a link to a tuto, I'll search for that.

I'll try to unplug any usb device and try a different USB plug, would there be a way to desactivate any process? I guess with CTRL alt-dell. I'm trying that right now. 

Community Manager
Community Manager

Tesla1856,

Below is snakeplisken77 PC specifications =
Aurora R8
Windows 10 Home
Nvidia RTX 2080 OC
32GB DDR4 2666MHz
i7-8700
512GB M.2 PCIe NVME SSD
2TB SATA

Top Contributor
Latest Solutions