CTopher84
3 Argentium

980Ti w/ Alienware Graphics Amplifier

Card: PNY Nvidia 980 Ti (reference card)

Drivers: 353.06 (nvidia site 980m Windows 8.1 64 bit driver)

Latest AGA software from Dell's update site (1.0.27.0, A02)

This card currently doesn't switch between Amp and Notebook card with the current drivers on a clean install. Appears to be the same issue that existed before with 980 cards where the hardware ids were not included in the mobile drivers.

The only workaround i've found to get the 980 Ti working is to connect to the Amp and uninstall then reinstall the driver through the .exe. 

To re-enable the mobile card, you'll have to uninstall and reinstall the driver through the .exe as well. The other workarounds i've posted in the past for the 980 do not work for the 980 Ti.

The 980 issue was corrected eventually so I am guessing this one will too. Just a heads up for anyone that is curious.

6/22/2015 Update:

353.30 does not work for me with my 980Ti and 980m

I did modify the Dell driver w/ the hardware ID for the 980Ti (17C8) and installed after disabling the driver signing and still no switching. The 980m was picked up just fine but when I plugged in the amp, i got nothing but "Microsoft Basic Display Adapter".

If you look in the nvdmi.inf (Dell's inf) You'll notice that 17C2 is the latest thing in there which is the Titan X. You can also see this in the [Strings] section of the driver.

Tags (1)
0 Kudos
33 Replies
Spike66s
1 Copper

RE: 980Ti w/ Alienware Graphics Amplifier

Yeah lol I'm going through same prob I have asus Gtx 980 ti same prob had tech support helping they said they know about the problem they said by August the driver will be realesed

0 Kudos
CTopher84
3 Argentium

RE: 980Ti w/ Alienware Graphics Amplifier

Awesome. Thanks for the update from talking to tech support. Should be resolved once NVIDIA pushes new drivers. Hang tight 🙂 Have fun w/ the install/reinstall until then. 

0 Kudos
Spike66s
1 Copper

RE: 980Ti w/ Alienware Graphics Amplifier

I recommend leaving the graphics amp plugged in when installing the ti drivers? Bc it's not recognizing the card

0 Kudos
CTopher84
3 Argentium

RE: 980Ti w/ Alienware Graphics Amplifier

Yes, leave the amp with the card attached when you install the drivers (clean install... uninstall then install). Should work with the card just fine. 


Also the new 6/22/2015 driver (353.30) does NOT fix the issue. I even modded NVIDIA's dell .inf file to include the 980Ti hardware ID (17C8) and still no switching. The latest card dell supports with it's .info is the Titan X.

0 Kudos
Tweian
1 Copper

RE: 980Ti w/ Alienware Graphics Amplifier

Wish i had seen this post before i went to the expense of getting a 980TI for my AGA.. Is there any news or updates or anything on when the AGA will actually get working drivers?

0 Kudos
Highlighted
CTopher84
3 Argentium

RE: 980Ti w/ Alienware Graphics Amplifier

No news on drivers yet. The entire issue is that they don't have the hardware IDs in the driver .ini files from what I've seen. I tried to mod it myself but didn't have any luck. I usually watch/contribute to these threads:

http://na.alienwarearena.com/forums/thread/83039/hardware-software/alienware-graphics-amplifier-faq


as long as you install/reinstall the drivers it will work with the card. Just kind of annoying to do that every time.

0 Kudos
CTopher84
3 Argentium

RE: 980Ti w/ Alienware Graphics Amplifier

New driver released today 353.62 for windows 10. Still at work so haven't been able to see if this resolves the issue. Will post back later unless someone else gets to it.

us.download.nvidia.com/.../353.62-win8-win7-winvista-desktop-release-notes.pdf

0 Kudos
wgolden30
1 Copper

RE: 980Ti w/ Alienware Graphics Amplifier

the new .62 nvidia driver doenst work with 980ti

0 Kudos
Tweian
1 Copper

RE: 980Ti w/ Alienware Graphics Amplifier

Works for me.

Just updated the nvidia driver with windows update, and i can now use both my 980M and my 980TI when its in the amplifier, without having to constantly reinstall drivers.

0 Kudos