CTopher84
3 Argentium

RE: 980Ti w/ Alienware Graphics Amplifier

Let me preface this with 99% of the time, accepting driver updates from Windows is not a good idea. They are out of date with what is out there and usually will do more harm than good. Just accept non-driver updates.

  1. Uninstall the windows 10 driver (should just say nvidia graphics driver in the control panel).
  2. Restart

Now you'll have the windows driver version off your system.

  1. Download the MOBILE nvidia driver version for your OS.
  2. Plug in GA
  3. Install mobile driver (it should unpack to C:\NVIDIA which you can just leave alone so future installs you just go to that folder and run the setup.exe)
  4. Restart
  5. The GA card should now be recognized. My monitor displays on boot after restart at least.

If you want to disconnect and use the mobile card again, you'll have to:

  1. Disconnect GA
  2. Uninstall Drivers
  3. Restart
  4. Reinstall Driver

You have to follow this process until Dell and Nvidia get their stuff together (which is VERY VERY long overdue) and add the hardware IDs to the driver INF so the card is recognized properly.

0 Kudos
Gordon5911
1 Copper

RE: 980Ti w/ Alienware Graphics Amplifier

I have solved mg issues . I own a new alienware m17 r2 with gtx 980m (windows 😎 and the GA with the titan x graphics card . I simply downloaded the latest mobile nvidia update for my onboard 980m I didn't have the graphics amplifier plugged into my laptop when I downloaded it. Then I plugged in the ga after applying the update and shutting down my laptop after restarting it worked and is still working... I've run all of my games one it.

So to recap

1 dowNload latest mobile nvidia update without GA ATTACHED

2 apply it

3 POWER DOWN AND PLUG IN GA

4 RESTART

5 upon logging in u your screen may flash once or twice ( I think its a blink of awesomeness)

6 game and develop until you drop

0 Kudos
CTopher84
3 Argentium

RE: 980Ti w/ Alienware Graphics Amplifier

There are no issues with the Titan X which is why it works fine. This thread is specifically for the 980 Ti which is a different card. The 980Ti should work the same way once the Dell and Nvidia get their stuff together.

0 Kudos
Han lei
1 Copper

RE: 980Ti w/ Alienware Graphics Amplifier

While I cannot even make my gtx980ti work with windows 10 and latest driver

0 Kudos
Highlighted
CTopher84
3 Argentium

RE: 980Ti w/ Alienware Graphics Amplifier

Is this a statement or comment? If you read the thread you will see that it does not work and that it is 100% a driver issue.

0 Kudos
CTopher84
3 Argentium

RE: 980Ti w/ Alienware Graphics Amplifier

Actually got the 980m and 980Ti to work this weekend. I uninstalled the driver completely, plugged in the AGA and installed 353.30 980m mobile driver. For whatever reason, the 980m is one driver version and the 980Ti is another. Maybe Windows 10 picks it up and auto installs? I don't know but It works just fine and I can plug the amp in and unplug it and the cards are picked up appropriately. This isn't optimal obviously since there are 2 different driver versions but it does work and allows you to switch without installing drivers every time.

0 Kudos
psihas
1 Copper

RE: 980Ti w/ Alienware Graphics Amplifier

Tried everything, and I mean everything.  Finally I had to go back to 8.1 and do the work around by installing the driver for the 980ti with a monitor every time i want to use it. 

None of the drivers of the 980ti work for me with the 17r2 integrated.  

I´m very disappointed and considering to sell the GA with the 980ti just to get my money back. 

Dell ***. 

0 Kudos
AriahNeptune
1 Copper

RE: 980Ti w/ Alienware Graphics Amplifier

I had to go back to 8.1 either. When i use the 353.30 desktop driver for 8.1 with my AGA plugged in i get my gtx 980ti to work properly. If i want to use the gtx 980m i have to unplug the AGA and install the 980m driver. If i want to use the gtx 980 ti again, i have to clear the system with the DDU and reinstall the 353.30 desktop drivers again....

thats the only way for me to get the gtx 980 ti to work with my 17 r2.

with windows 10 i found no way to get my 980 ti running

0 Kudos
CTopher84
3 Argentium

RE: 980Ti w/ Alienware Graphics Amplifier

My post a few posts up is for Windows 10. The switching works fine now but there are 2 different driver versions in the control panel depending on which card is active (980m vs 980Ti). No issues so far though switches just fine although I would PREFER the driver versions be the same for potential issues.

0 Kudos
isitizet
1 Copper

RE: 980Ti w/ Alienware Graphics Amplifier

OK after a day of testing and thinking it through i came up with a solution guys and these are the step by steps 

1. uninstall all nvidia drivers for your gtx 980ti manually or using ddu

2.restart and download the latest drivers for nvidia drivers  however do not perform a clean instal im using the newest one with you amplifier pluged in and card in

3.do not launch geforce expirience  and do not restart

4.delete your intel integrated graphics card  amazingly intel launched a driver today as well for the 4600 intel cards 

5. download the driver from communities.intel.com/thread/77726 


6. do not install. but place on desktop

7.shutdown your pc 

8. turn it on 

9. install. the intel driver.

10. do not attempt to launce any programs or the intel comand center  

11. install the latest nvidia driver again you previously downloaded and installed 

12.run ge force expirience 

13. play any game using yout gtx980ti

0 Kudos