Highlighted
aparsh135i
1 Nickel

AW 15 R2 Cannot update BIOS without battery, tried rufus & /forceit - help please

Hello,

I've spent hours troubleshooting this Alienware 15 R2 i have here.  I bought the unit as-is with no SSDs or HDDs installed.  I bought a Samsung 951 Pro 256gb M.2 NVME drive but windows will not let me use it as a boot drive and it is not detected in bios. Everything i read pointed to updating BIOS (which appears the BIOS is very outdated).

However this unit also has a bad battery.  I ordered a new battery which ended up being dead too, so wont have the next replacement battery for over a week.  I'd really like to get the OS set up on this in the mean time with just the AC adapter.

I've read guides online (mainly this one http://superuser.com/questions/879545/how-can-i-update-bios-without-battery

I rufus'd a flash drive and tried forceit and i got Run-time Error R6000 - stack overflow every time.

 

I've tried running command prompts to try doing it from inside a windows 10 environemtn from a regular 1TB HDD but no luck with that either, for whatever reason i cant get CMD to operate correctly. '

Does anyone have any advice?

0 Kudos
1 Reply
Moderator
Moderator

RE: AW 15 R2 Cannot update BIOS without battery, tried rufus & /forceit - help please

Hi,

You won't be able to update the Bios without the battery, but in the mean time you can check the link below, it might help you with the SSD setup:

en.community.dell.com/.../19989934

Alienware Arena

Alienware-Eimy
Dell | Alienware Technical Support
#IWork4Dell
Opening your case does not void your warranty! Check out Alienware Artificial Intelligence
I can't always reply to PM's, if you need extra assistance visit: YouTube Logo Facebook Logo Twitter Logo

0 Kudos