Highlighted
BellaAngela
1 Nickel

AlienFusion Memory Leak after upgrade to Win7

After upgrading to Windows 7, the AlienFusion service is developing a horrible memory leak.  Task manager reports it's eating up over 800MB of memory and all four cores of my processor are getting slammed, up to 80% busy.  If I end the AlienFusionService.exe process, core usage across the board drops to less than 10%. 

Personally, the entire Alienware Command Center is kludgey and prone to lockups.  Basic theme colors are too limited in AlienFX, AlienSense takes much too long to initialize, and now this problem with the AlienFusion service.  Pretty sloppy for a $4000 computer (m17x). 

Others are having this issue, found a thread here: http://forum.notebookreview.com/showthread.php?t=415530

0 Kudos
17 Replies
BellaAngela
1 Nickel

Re: AlienFusion Memory Leak after upgrade to Win7

Here is a screenshot of the task manager.  You can see that the AlienFusionService.exe image is taking up 2.74 GB of memory.  Once I manually shut down this service, the system is responsive and CPU usage drops to under 10%.  This was not happening under Vista.  I think I can work around this by setting the service to manual from automatic, but then I lose power management.

0 Kudos
Mister_Earl
1 Nickel

Re: AlienFusion Memory Leak after upgrade to Win7

Same issue here except the Alien Fusion Service was taking up over 3.5GB.  Shutting down the service does eliminate the problem. 

0 Kudos
Not applicable

Re: AlienFusion Memory Leak after upgrade to Win7

Same problem, seems happen randomly, i can't stay a full day without problem, and sometimes one hour after the boot all the memory is taken by the process. I go uo  to 3.8 GB and everithing became very slow.

0 Kudos

Re: AlienFusion Memory Leak after upgrade to Win7

Hello,

Thank you for bringing this situation to our attention by posting it in the forums.

What is the current Command Center version all of you are running on your machines?  You should have Command Center 2.0.10.  If not go here for the update. 

Regards,

 

 

0 Kudos
Steven P
2 Iron

Re: AlienFusion Memory Leak after upgrade to Win7

I have the update R232274 installed

Version 2.0.10, A03 released 10/9/2009

Alien Fusion does not work.  After install, when I open the command center, Fusion is blank.

Alienware Area-51 M17x
MS Windows 7 Ultimate 64
Intel(R) Core(TM)2 Duo CPU P8700 @ 2.53GHz
NVIDIA GeForce GTX 260M
4GB RAM DDR3 1333MHz
Windows Experience Index base score of 5.9
Windows Graphics Experience score is 6.8


Alienware M17x "R1"
Bios A07
Intel(R) Core(TM)2 Duo CPU P8700 @ 2.53GHz
8GB RAM DDR3 1333MHz
NVIDIA GeForce GTX 260M
SSD: Samsung 830 HDD: ST95005620AS Seagate Momentus XT
MS Windows 7 Ultimate 64

Dell XPS 13 i5 128GB

0 Kudos
Mister_Earl
1 Nickel

Re: AlienFusion Memory Leak after upgrade to Win7

That might be a separate issue.  Updating to the 2.x.10 version of the command center fixed the memory leak on my box.

 

That being said, even when I was experiencing the memory leak, I could always open up fusion and see it.  It was never blank for me.

0 Kudos
CaioCost
1 Nickel

Re: AlienFusion Memory Leak after upgrade to Win7

I've had the same problem with the alienfusion memory leak, and i've updated the command center with the link that DELL-Richard B

gave us up there, it seems that the problem with the memory has been solved but now, the command center doesn't have a lot of options such as Advanced theme for AlienFX, even the text labels of the icons doesn't appear.. 

0 Kudos
Mister_Earl
1 Nickel

Re: AlienFusion Memory Leak after upgrade to Win7

Here's something I just remembered.  I did have the blank Fusion issue when I upgraded command centers, but not to this one.

When I installed the command center for the Tact-X mouse, Fusion was gone.  The fix for that was to do a complete uninstall of the old command centers FIRST, then install the new version.  Installing one version over the other for some reason doesn't work. 

 

When I updated to this version of the command center to fix the memory leak, I uninstalled the previous version first.  Try uninstalling all command centers then installing this one and see if that works.

0 Kudos
Steven P
2 Iron

Re: AlienFusion Memory Leak after upgrade to Win7

My Installation of Command Center was on a clean install.

Fusion still will not work.

Fusion Service and controller are running in task manager.

This is not a big deal.  I don't really need it.  But would be cool if it did work.

Alienware M17x "R1"
Bios A07
Intel(R) Core(TM)2 Duo CPU P8700 @ 2.53GHz
8GB RAM DDR3 1333MHz
NVIDIA GeForce GTX 260M
SSD: Samsung 830 HDD: ST95005620AS Seagate Momentus XT
MS Windows 7 Ultimate 64

Dell XPS 13 i5 128GB

0 Kudos