Highlighted
Syric
2 Iron

Alienware 17 R3 - Slow Keyboard backspacing issue/fix

All,

Ok, this one has been bothering me all the way back to when I first purchased my Alienware 17 R3 in Feb 2016. Apparently, at random points in using my AW laptop, the back-spacing response changes to a very slowwwwwww motion. To articulate/explain, it deletes a typed character, then there is a .50-1 sec delay in deleting this next one. Why? You tell me us Dell Mods....potential glitch? bug? can you fix it?!

Solution (for now):  Go to your Windows >> Control Panel >> Keyboard >> Speed tab

Once there, move the sliding bar under "Repeat delay:" and "Repeat rate:" ....doesn't matter in which direction. Then, move the sliding bar to your original setting or your preferred preference .

Now, click "Apply" 

The issue with the back spacing "extended time delay" will now be "fix" / "resolved" ....until your Dell Alienware rig decides to do it again .....and it will....

Dell MODs note: Even setting the default settings to the Shortest and Fastest repeat delay does not fix this indefinitely. I will eventually have to do what I outlined above to resolve it.

Additionally, rebooting or shutting down can also alleviate the issue....again, until it happens again randomly.

0 Kudos
1 Reply
Tesla1856
6 Gallium

RE: Alienware 17 R3 - Slow Keyboard backspacing issue/fix

I would try a new keyboard and/or a clean-install of Windows-10/64bit. Test before installing AW-CommandCenter since it interacts with keyboard and might be interfering.


Registered Microsoft Partner and Apple Developer
- Like many of you, I can appreciate a good game-engine.
- I answer questions here, but I'm not a Dell employee.
- Consider giving posts you like a "thumbs-up"
- Posting models-numbers and software versions speeds trouble-shooting.
- Click "Accept as Solution" button on any post that answers your question best.
0 Kudos