Highlighted
kuriandungu
1 Nickel

Alienware 18 Killer e2200 NIC Issue -SOLVED

I connected a network cable to my Alienware 18 for the first time today. No connection was detected even though testing on other laptops proved that the cable was fine.

In the Network connections there is a virtual vEthernet (Killer e2200 Gigabit Ethernet Controller (NDIS 630...) but if i try and install any Killer software drivers or manager I get the error "No Killer Hardware was detected".

I have tried manually installing the drivers again in device manager by selecting the correct drivers manually from the inf folder. however on boot the pc crashes and has to do a restore. The error is NDIS.SYS Error.  

I ran the diagnostic function on the support site and it reported that my network card was a Killer e220x and it passed the pci test.

My last resort is to do a respawn and hope taking it back to factory settings will do the trick. I'm hoping it wont come to this because as a developer I'll spend a couple of days just installing and configuring stuff to where i was before the restore.

Anyone had this problem and resolved it?

Alienware18_noNetwork.png

RESOLVED.

I used AlienRespawn to recover just the system partition from a backup i'd made. I was very happy to see the network already connected by the time it rebooted. 

Thanks to anyone who took time to read and think about how to help.

0 Kudos
1 Reply

RE: Alienware 18 Killer e2200 NIC Issue -SOLVED

Thank you for sharing this with the Alienware Community. It sounds like it might have been a conflict with the Killer driver software. 

Alienware Arena

Alienware-Rodrigo
Dell | Alienware Technical Support
#IWork4Dell
Opening your case does not void your warranty! Check out Alienware Artificial Intelligence
I can't always reply to PM's, if you need extra assistance visit: YouTube Logo Facebook Logo Twitter Logo

0 Kudos