ddbug
1 Copper

Alienware 18 R3 - USB3.0 Port Dysfunctional

I have an Alienware 18 R3, currently running Win8.1.  It has four USB3.0 ports, with one of them having PowerShare.

Previously, when it was running Win10, I kept receiving the alert stating something like "USB port overcurrent".

Then, I formatted the system disk C: and reinstalled Win8.1, BIOS 12 and all the recommended drivers and software from Dell support site.

Now, one USB port became dysfunctional anyway.  The other three worked with USB memory sticks and portable HDDs, but only the one with PowerShare worked with external mouse and touchpad. 

When I run the hardware check from Dell, analyzing USB ports, it shows: Devices causing overcurrent:  2 items, and devices with general failures: 1 item, functioning devices: 5 items, while I actually did not plug in any USB devices in the ports.

Could someone help with this issue?  Is it caused by software or hardware (motherboard)? 

Many thanks for your help in advance!!!

0 Kudos
1 Reply
Moderator
Moderator

Re: Alienware 18 R3 - USB3.0 Port Dysfunctional

Hi ddbug,

I'm guessing you're talking about the AW18R1 there is no R3. This sounds like a motherboard issue. But you can try a power drain: unplug every external device from the system (including the AC Adapter), open the bottom cover and disconnect the battery cable from the system. Then hold the power button for around a minute to drain all the power.

Also, try a BIOS update but if the issue persists, it means that the problem is related to the motherboard.


Alienware Arena

Alienware-Eimy
Dell | Alienware Technical Support
#IWork4Dell
Opening your case does not void your warranty! Check out Alienware Artificial Intelligence
I can't always reply to PM's, if you need extra assistance visit: YouTube Logo Facebook Logo Twitter Logo

0 Kudos