Highlighted
Okfloorit
1 Nickel

Alienware Aurora (Late 2009) Updating BIOS from version A05. Help!!

Hello everyone,

I've been attempting to find a way to update the BIOS for my machine (Alienware Aurora (Late 2009)) but have been having issues.

The only BIOS update available under Dell's Product support for this machine is version 'A11' and isn't working for my machine which is on update version 'A05'.

I attempted to call in to Dell support to hopefully get some of the previous BIOS versions so I could flash my way up to version A11- but to no avail.  

Is there anyplace previous BIOS versions might be that I've missed? 

 

Thanks for any help you can provide!

0 Kudos
8 Replies
Cass-Ole
4 Ruthenium

RE: Alienware Aurora (Late 2009) Updating BIOS from version A05. Help!!

Repository of Aurora Software from the Dell FTP server:

Give the following a read, it has links to other posts. If you 're at A05 it may be wise to move to A07 then A09 1st, b4 A11, some might say try A09 then  A11.

I don't have an opinion or advice, short of if you are under warranty, call in to support as you flash the bios, so that if it bricks you have possible recourse in getting a new mthrbrd. I can't help with a failed update or bricked mthrbrd, all I have is the links in this post, above/below.

0 Kudos
Okfloorit
1 Nickel

RE: Alienware Aurora (Late 2009) Updating BIOS from version A05. Help!!

Thanks for the response

That model however slightly differs from my Alienware Aurora. My model is literally called Alienware Aurora (Late 2009). No other Alienware model driver seems to work with my board and gets rejected when I try to download that driver.

As with the drivers you linked don't quite work in my case.

Still looking for a valid BIOS update if anyone has any other ideas/ areas!

0 Kudos
FalconW7
2 Iron

RE: Alienware Aurora (Late 2009) Updating BIOS from version A05. Help!!

what cpu and chipset do you have? My Aurora 2009 has a x58 chipset with an intel i7-960

I am running bios a11

Alienware Aurora - i7 960 - EVGA 970GTX FTW - 12GB DDR 1600Mhz - 1x160GB  Intel 320 SSD - Seagate 2x1TB - WD Black 2TB - SB X-Fi Titanium - 24xdvd burner - Windows 10 Prof 64bit - U2410 - TactX keyboard and mouse - Logitech Performance MX

0 Kudos
Cass-Ole
4 Ruthenium

RE: Alienware Aurora (Late 2009) Updating BIOS from version A05. Help!!

0 Kudos
Cass-Ole
4 Ruthenium

RE: Alienware Aurora (Late 2009) Updating BIOS from version A05. Help!!

did u see I edited in the R1 Historical software link a few minutes after I posted ... I get the feeling you have the x58 Intel ...

0 Kudos
Okfloorit
1 Nickel

RE: Alienware Aurora (Late 2009) Updating BIOS from version A05. Help!!

Sorry for not including this sooner! I'm pretty certain I found the right model through the link you provided Cass.

My specs:

Intel i7 2600k

NVIDIA gtx 680

16gb ram

128gb Samsung Evo 840 SSD

I did try the BIOS updates for my model and they go through successfully now, However my machine reboots and sticks with the A05 BIOS version.

Pretty annoying haha

0 Kudos
FalconW7
2 Iron

RE: Alienware Aurora (Late 2009) Updating BIOS from version A05. Help!!

You have the Alienware Aurora R2.

Alienware Aurora - i7 960 - EVGA 970GTX FTW - 12GB DDR 1600Mhz - 1x160GB  Intel 320 SSD - Seagate 2x1TB - WD Black 2TB - SB X-Fi Titanium - 24xdvd burner - Windows 10 Prof 64bit - U2410 - TactX keyboard and mouse - Logitech Performance MX

0 Kudos
Okfloorit
1 Nickel

RE: Alienware Aurora (Late 2009) Updating BIOS from version A05. Help!!

So now that I have the correct BIOS updates to choose from, any ideas why it would say it successfully installs the BIOS update and then stays on the 'A05' BIOS version after a reboot?

0 Kudos