dlserver
Bronze

Re: Alienware Aurora R6 Booting Linux on PCIe M.2

I can also attest to being unable to successfully boot Ubuntu (16.04 server) on the R6's NVME drive. The installation itself seems to work fine, but it boots to a black screen. I highly doubt this has anything to do with NVIDIA drivers because I was able to install them, just unable to boot the machine afterwards.I have tried the latest BIOS 1.0.9 and all possible hardware settings and GRUB settings. They all end up in a black screen at various times. I thought I made progress after updating BIOS because I got into my Ubuntu log-in screen. However, I got a black screen again after rebooting. This is such a disappointment. Those of you who were hoping to use R6 for machine learning/deep learning purposes may want to look elsewhere. 

0 Kudos
dlserver
Bronze

Re: Alienware Aurora R6 Booting Linux on PCIe M.2

Guys, I got Ubuntu 17.04 to work. Hibernate does not work, but all other systems are go.  My NVME drive is by Liteon. The firmware was up to date, but you may want to check yours. The main steps were:

1. Update bios to 1.09

2. Install Ubuntu 17.04

3. In GRUB, choose advanced options for Ubuntu and boot with secure mode

4. Install NVIDIA drivers. Open blacklist.conf and blacklist 

blacklist vga16fb 
blacklist nouveau
blacklist rivafb
blacklist nvidiafb
blacklist rivatv
blacklist i2c-designware-platform
blacklist i2c-designware-core

I received 'kernel panic' until I blacklisted i2c-designware. 

I also disconnected my second HDD to make everything more simple. That may not be necessary.

Good luck!

0 Kudos
Not applicable

Re: Alienware Aurora R6 Booting Linux on PCIe M.2

where can i get 1.09 bios? dell.com only supply 1.03 bios now. thank you.

0 Kudos
dlserver
Bronze

Re: Alienware Aurora R6 Booting Linux on PCIe M.2

That's bizarre. They seem to have taken both 1.09 and 1.07 down from the website. It's either temporary glitch or they have discovered something alarming about them. In the meantime, you can still attempt installing Ubuntu 17.04. I think the main problem had to do with the kernels in 16.04. 

0 Kudos
Not applicable

Re: Alienware Aurora R6 Booting Linux on PCIe M.2

could you send me 1.09 bios? my email is cvieri@163.com.

thanks a lotSmiley Happy

0 Kudos
messi1010
Copper

Re: Alienware Aurora R6 Booting Linux on PCIe M.2

Hi,

1. Did you change the sata from RAID ON to AHCI?

2. Can you enter the USB live mode without black screen?

Thank you!

0 Kudos
dlserver
Bronze

Re: Alienware Aurora R6 Booting Linux on PCIe M.2

Yes to both. However, I don't understand why the black screen is such a big problem to everyone. I have always been able to boot to (advanced options ->) recovery mode to do necessary changes. The other option is to SSH to the machine if you have included openSSH during installation. 

I should add that I went back to 16.04 (on a Samsung SSD) yesterday. There will simply too many issues with the kernels on 17.04. In particular, if you are planning to install CUDA and deep learning libraries, I highly recommend 16.04. There are so many pieces that need to work together (OS kernels, CUDA, cudnn, keras, theano/tensorflow, compilers, etc.)

0 Kudos
messi1010
Copper

Re: Alienware Aurora R6 Booting Linux on PCIe M.2

Thanks man,

Did you install windows on non-m.2 ssd? Because I can boot windows from m.2 ssd. My solution is to install window on a sata 2.5 ssd.

0 Kudos
dlserver
Bronze

Re: Alienware Aurora R6 Booting Linux on PCIe M.2

Nope, I kept it on the m.2. To be honest, I don't really use Windows on the machine because I run it as an Ubuntu server and SSH from a Windows laptop. Such a waste of a good drive...

0 Kudos