Highlighted
madisonejames
1 Copper

Alienware m17x R4 Windows 8 Targus USB 3.0 Dual Video Docking issues.

Hardware:

  • Dell Alienware m17x r4
  • NVIDIA GeForce GTX 675M (9.18.13.697)
  • Intel HD Graphics 4000 (9.17.10.2817)
  • Targus USB 3.0 Dual Video Docking
    • http://tinyurl.com/c97pvqq

BIOS:

  • A09 

Issue:

  • When attaching the Targus dock to any USB3.0 port the main laptop display just start blinking on and off, and will not stop until the device is disconnected. This issue occurred on the upgrade install of Windows 8, and a clean install. This issue does not happen on Windows 7 x64 Ent.

What I have tried:

  • I have installed all the latest Video/DisplayLink drivers, which are all Windows 8 drivers.
  • I have tried both an upgrade to Windows 8 and a clean install.
  • I have rebooted the laptop several times, and have cycled the power on the Targus dock.

I have not found any information on this issue so it may be very new, and help would be greatly appreciated.

0 Kudos
2 Replies
chad11269
1 Nickel

Re: Alienware m17x R4 Windows 8 Targus USB 3.0 Dual Video Docking issues.

I have exact same issue but with new XPS 15 with factory installed Windows 8.  Everything appears to be installed properly, DisplayLink icon available, multiple monitors available...when I enable them the laptop screen flashes continuously until I disable.  Dell should not sell this Targus dock as if it is compatible, this system will be returned.

0 Kudos
chad11269
1 Nickel

Re: Alienware m17x R4 Windows 8 Targus USB 3.0 Dual Video Docking issues.

madisonejames everything worked fine with Win7?  I may try putting 7 on my XPS just for fun before I return.

0 Kudos