Highlighted
Jcarlson86
1 Copper

Alienware x51 r2: uninstalled geforce nvidia drivers/can't detect monitor/can't get to safe mode

Does anyone know how to get drivers loaded . Can't get monitor to detect and changing bios to secure boot-off to try to get to dart disc now wont even pick up the bios on the monitor, it did before trying to boot to dart. This is a win 8.1 machine. The goal was to upgrade the graphics card  to a geforce 1080 but when we did it detected the monitor for a minute booting into is. Reverted back to default video card, uninstalled  drivers (didn't know we were supposed to) and the screen went black. Maybe reset the cmos ? Not sure how to on the r2, any help would much appreciated!

0 Kudos
1 Reply
Tesla1856
6 Thallium

RE: Alienware x51 r2: uninstalled geforce nvidia drivers/can't detect monitor/can't get to safe mode

Was the original video card an AMD? Even so, re-installing it to uninstall drivers is a bit extreme. I just use Express Uninstall all AMD and Catalyst software (but can't say I've ever tried it without an AMD card installed).

If x51-R2 doesn't work in original config, sounds like something got blown-up with all the jacking around.

Service Manual should show CMOS jumper or just remove CMOS battery for a while.

Pretty sure GTX-1080 is beyond the power-abilities of it's baby power-supply.


Registered Microsoft Partner and Apple Developer
- Like many of you, I can appreciate a good game-engine.
- I answer questions here, but I'm not a Dell employee.
- Consider giving posts you like a "thumbs-up"
- Posting models-numbers and software versions speeds trouble-shooting.
- Click "Accept as Solution" button on any post that answers your question best.
0 Kudos