Highlighted
RichUT
6 Indium

Blu-Ray HDMI output issues on M17x

I am experiencing something odd when trying to output a blu-ray movie from my M17x to my Sharp LCD TV.  (A single HDMI cable is running directly from my M17x to my Television) 

I set the default audio output device (in Windows) to be the HDMI port before opening PowerDVD. 

After starting up PowerDVD, I move to the audio tab and select SPDIF as the prefered audio output method.  I hit play on the player and I get a beautiful picture, but no sound.

My Aqous TV displays a message that says "unsupported Audio format detected" and I get no sound whatsoever.

In any other Windows application, the sound comes through my TV perfectly fine.  However, the one application where I REALLY want the sound to work, isn't working at all.

I have tried working with Cyberlink on this issue, but thought I would ask in this forum as well, as I was really counting on being able to use the blu-ray drive to watch movies on my TV.

Thoughts?  Suggestions?

0 Kudos
6 Replies
8 Krypton

Re: Blu-Ray HDMI output issues on M17x

Computer hdmi can be just video, depending on your video card. Try adding audio cables from the sound card line out to the tv.

0 Kudos
RichUT
6 Indium

Re: Blu-Ray HDMI output issues on M17x

I get sound on everything EXCEPT the PowerDVD application, so it is not video or sound card related.  Quicktime, Windows Media Player, YouTube, etc.  I hear audio through my TV on all of those applications.

Yes, I can run cables to the TV, but that is a pain to deal with.  I have to change settings on the TV.  I just want it to work the way anyone would expect it to.

0 Kudos
fc2462
1 Copper

Re: Blu-Ray HDMI output issues on M17x

I'm having this exact same problem.  Dell needs to address this as I'm finding it's widespread.

Is there anyone out there with the newest style Dell Alienware M17x with a blue ray player (BD-ROM) that can output both picture and sound through their HDMI port?  I'm starting to think not.

 

0 Kudos
Camazotz
1 Copper

Re: Blu-Ray HDMI output issues on M17x

I'll test it this weekend, but from the sounds of it, it is an issue with PowerDVD and not necessarily with the laptop.  What OS are you running?  Windows Vista or Windows 7?

Have you done any troubleshooting, such as switching the audio outputs while the HDMI is connected?

0 Kudos
fc2462
1 Copper

Re: Blu-Ray HDMI output issues on M17x

I'm running Vista Ultimate 64.

 

 

0 Kudos
kootsvayouma
6 Indium

Re: Blu-Ray HDMI output issues on M17x

I have an Alienware M15x Laptop and have this same issue.  If I connect my laptop to any HDMI output, I get full audio and video from the basic connection (applications, games, etc) unless I use the Blu-Ray DVD software.  When I try to play a Blu-Ray DVD with the bundled software (PowerDVD 😎 I get audio from the menu screens.  When I select and play the movie, I get no audio.  The software gives me three SPDIF options:  Only Primary Audio, Dolby Digital Mixing, and DTS Mixing.  None of these options give audio during movie playback.

I can't imagine Dell bundled software which doesn't work, but it appears this is the issue.  Or, the soundcard drivers aren't properly handling the digital audio stream when it switched from the menu audio to the movie audio.  I tried to update my audio drivers, but there is no updates available.  I also upgraded to PowerDVD 10 (from bundled PowerDVD 😎 and this has made no difference.

-Koots

0 Kudos