DRIVE_POWER_STATE_FAILURE BSODS + Disappearing Sound issue on M17X R4

So right after buying the Alienware M17X R4 with the HD 7970M I started getting these DRIVE_POWER_STATE_FAILURE blue screens of death whenever on battery. Simultaneously, I began losing sound. Sometimes after turning on the laptop, often after it resumes from sleep. Every day I have sound issues and every day I crash 1-3 times with that blue screen message (when on battery). I am forced to always stay plugged in, but I still have the sound issue. 

I updated the drivers. All of them - display drivers, sound drivers, etc. I reinstalled the OS. I flashed the BIOS. I searched the forums. Right now, I am kinda out of options. 

I used to think this was the AMD Enduro graphics switching driver problem, but I disabled graphics switching and began using the HD 7970M exclusively. I also looked up this issue and found out it was happening on the NVIDIA Optimus system as well. 

Anyone have any ideas?

Thanks. Smiley Happy

P.S. Log of the BSOD:

Problem signature:
Problem Event Name: BlueScreen
OS Version: 6.1.7601.2.1.0.768.3
Locale ID: 1033

Additional information about the problem:
BCCode: 9f
BCP1: 0000000000000003
BCP2: FFFFFA80120A8740
BCP3: FFFFF80000B9C3D8
BCP4: FFFFFA800E17E010
OS Version: 6_1_7601
Service Pack: 1_0
Product: 768_1

Files that help describe the problem:
C:\Windows\Minidump\101512-16052-01.dmp
C:\Users\User\AppData\Local\Temp\WER-23883-0.sysdata.xml

Read our privacy statement online:
http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
C:\Windows\system32\en-US\erofflps.txt

***M17X R4***

Intel Core i7 3610QM  @2.3-3.3GHz/ 16GB RAM / 60GB SSD + 750GB 7.2K RPM HDD / AMD Radeon HD 7970M 2GB

0 Kudos
4 Replies
morblore
5 Rhenium

Re: DRIVE_POWER_STATE_FAILURE BSODS + Disappearing Sound issue on M17X R4

So right after buying the Alienware M17X R4 with the HD 7970M I started getting these DRIVE_POWER_STATE_FAILURE blue screens of death whenever on battery. Simultaneously, I began losing sound. Sometimes after turning on the laptop, often after it resumes from sleep. Every day I have sound issues and every day I crash 1-3 times with that blue screen message (when on battery). I am forced to always stay plugged in, but I still have the sound issue. 

 

I updated the drivers. All of them - display drivers, sound drivers, etc. I reinstalled the OS. I flashed the BIOS. I searched the forums. Right now, I am kinda out of options. 

 

I used to think this was the AMD Enduro graphics switching driver problem, but I disabled graphics switching and began using the HD 7970M exclusively. I also looked up this issue and found out it was happening on the NVIDIA Optimus system as well. 

 

 

Anyone have any ideas?

 

 

Thanks. Smiley Happy

 

 

P.S. Log of the BSOD:

 
Problem signature:
Problem Event Name: BlueScreen
OS Version: 6.1.7601.2.1.0.768.3
Locale ID: 1033

Additional information about the problem:
BCCode: 9f
BCP1: 0000000000000003
BCP2: FFFFFA80120A8740
BCP3: FFFFF80000B9C3D8
BCP4: FFFFFA800E17E010
OS Version: 6_1_7601
Service Pack: 1_0
Product: 768_1

Files that help describe the problem:
C:\Windows\Minidump\101512-16052-01.dmp
C:\Users\User\AppData\Local\Temp\WER-23883-0.sysdata.xml

Read our privacy statement online:
http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
C:\Windows\system32\en-US\erofflps.txt

 


Hello Aemilius Paulus

Your mini dump file is located here: C:\Windows\Minidump\101512-16052-01.dmp 
You can download this program for free and it will open and read it: http://www.nirsoft.net/utils/blue_screen_view.html

The sound issue could just be part of the BSOD. Often the sound will go out or go into a loop when have a computer crash. If the sound issue happens right around the same time the BSOD occurs then most likely that is what is going on. Update the sound driver or reinstall it with a new/older version just to be safe. You could also try to diable the sound in the BIOS if you want to rule it out as the cause. 

A lot of the trouble shooting tips are for the M14X but since the issue is pretty much the same one of them could solve it for you

Read this thread please and try these steps that Dell Chris-M posted: http://en.community.dell.com/owners-club/alienware/f/3746/p/19468742/20194905.aspx#20194905


* Power the M14x-R2 off
* Remove the battery
* Disconnect the AC adapter
* Press and hold in the M14x power button for 5 seconds
* Reinstall the battery
* Connect the AC adapter
* Power the M14x on
* Make sure the battery charging indicator is working
* Disconnect the AC adapter
* The icon should change to show that the M14x is using the battery
Test the M14x



After doing that and it still BSOD then go here and read this thread please. It has a few more things for you to try. : http://en.community.dell.com/owners-club/alienware/f/3746/p/19441457/20072519.aspx


Alienware Frank_L wrote:

Hello, #Iwork4AW. This is the best way to fix the issue: http://dell.to/H24Zdr or this one: http://dell.to/H2aoAO if it is a different issue.
The New Bios and Nvidia Driver we released should take care of that. If after this, the problems seem to continue; please send us an email to AWCC-Resolution_Experts@dell.com with the service tag and contact information so we can get a solution. Thank you

Frank L


****** IF YOU DECIDE TO UPDATE THE BIOS PLEASE CONTACT TECH SUPPORT AND HAVE THEM HELP YOU. IF YOU DO NOT DO IT RIGHT IT COULD BRICK YOUR SYSTEM*******



__________________________________________________________________________________________

Area-51 Cosmic Black/Windows 8 64-bit Pro/BIOS A11
Intel Core i7-980x Extreme Edition @ 4.0 ghz/Intel 160gb X-25M SSD Raid-0
6GB Corsair Dominator GT 1866 DDR3/PNY GeForce GTX 680 SLI/ATI TV Wonder

 

0 Kudos

Re: DRIVE_POWER_STATE_FAILURE BSODS + Disappearing Sound issue on M17X R4

Well, the sound issue seems to be a common problem that most linked to the graphics switching. I already updated the sound drivers though. I downloaded *every* single driver there was on the Dell site for my laptop. Well, every single one that applied to my hardware configuration, that is. I tried the original and the new drivers.

The sound issue appears to act independently in relation to the BSODs. They do not coincide. Only once. Every other time, it's usually the sound going out after booting up or *especially* after resuming from sleep. Again, I disabled graphics switching.

The funniest thing is that I am an IT guy myself and I repair around 50-100 laptops a month. Down to component-level repairs at time (BGA reflows on certain models that benefit from them and don't <ADMIN NOTE: Profanity removed as per TOU> out afterwards). But the joke is that this beauty of an M17X R4 is my personal laptop and it's one of the handful of laptops that stumped me.

I mean, this has all the makings of a half-baked driver release. Unsurprising, given AMD's reputation for graphics drivers. I am still an AMD fanboy though, for now, hehe. Can't beat the raw gaming power (I don't use NVIDIA CUDA) and the cost effectiveness. I hope drivers will fix this. That being said, I've heard of the NVIDIA-based third-revision M17X laptops with the same BSOD. That worries me. Seems like a persistent defect, morelike.

So you are saying that I should clear CMOS? By removing battery and holding down the power key? One thing I have to say though, I've never, ever seen a laptop battery causing issues like these. The only few times I have seen this it turned out to be the motherboard, not the battery. Batteries are simple. That link says it's a battery issue. I am not really sure. But clearing CMOS can fix issues, yes,

Thanks Smiley Happy

***M17X R4***

Intel Core i7 3610QM  @2.3-3.3GHz/ 16GB RAM / 60GB SSD + 750GB 7.2K RPM HDD / AMD Radeon HD 7970M 2GB

0 Kudos
morblore
5 Rhenium

Re: DRIVE_POWER_STATE_FAILURE BSODS + Disappearing Sound issue on M17X R4

Follow the steps Dell Chris-M posted for the M14x first.


I'm with the idea it could be driver related too but I guess it could always be a failing peice of hardware and most likely the battery. But you should rule out everything you can before spending the money on one. I say go ahead and clear the CMOS...won't hurt anything. Make sure you write down your BIOS settings before doing it. Also, when the system comes back up you will want to go back into the BIOS and reset it to default, save settings and do a reboot. Then put your BIOS settings back.

This issue is popping up on a few Alienwares so that does sound like it's more a BIOS/hardware related then anything else because of the different system specs. If the same issue is on a AMD and Nvidia system then what does that tell you? A bad battery would account for this but it can't be the GPU drivers. Hmm... Ok maybe BIOS..right? Or maybe the mobo? Both could account for the sound too. Is the BIOS up to date?

Hit the F12 on boot and run the pre-boot system test if you have not tried it yet. See if it gives you any errors.

The sound issue should be easy to fix for someone like yourself. It will be a bad card, bad driver or maybe a PCI issue. A PCI issue could also cause the power state BSOD. This is an idea. Next time you are at work and you have a laptop with a sound card that will be sitting around on your bench for a week or so waiting for parts...pull the sound card and test it in yours. Just a thought.

Latency issues can cause the sound trouble you are having too but it sounds like you already know this. Not much can solve that but drivers or hardware replacment. I had one system that it was never fixed on, it was just one of the downsides of the board I was using. I'll never touch a mobo made by Nvidia again btw


On my list. Bad battery, bad mobo, bad card and bad drivers....one of these. Battery is by far on the top of the list lol. I'm using a shotgun here since it sounds like you know what you are doing. Just giving some ideas.

__________________________________________________________________________________________

Area-51 Cosmic Black/Windows 8 64-bit Pro/BIOS A11
Intel Core i7-980x Extreme Edition @ 4.0 ghz/Intel 160gb X-25M SSD Raid-0
6GB Corsair Dominator GT 1866 DDR3/PNY GeForce GTX 680 SLI/ATI TV Wonder

 

0 Kudos
Moderator
Moderator

Re: DRIVE_POWER_STATE_FAILURE BSODS + Disappearing Sound issue on M17X R4

This thread has been locked due to inactivity. For assistance, with the same or a different issue, please click New Post on the top right to start a New Thread.                                                                                                

0 Kudos