Highlighted
Wagglestein
1 Copper

M14x R2 Won't Connect Wirelessly

I've had my M14x R2 for less than a month and about a week ago the wireless stopped working when it was plugged into power. I tried everything and nothing worked so I I used the Alienware Respawn to bring it back to factory settings, and now it doesn't connect wirelessly at all. My specs are:

Windows 7

Intel i7 3630qm

12GB Ram

1TB hard Drive

Killer Wireless Card

2GB nVidia Graphics..

I've made sure the drivers are up to date, that the card is enabled and functioning, that everything is being gathered and generated automatically. One thing I did notice during ipConfig is that I don't have a default gateway listed.

I can see every network on my block but I just can't connect, after like 2 minutes it will say unidentified network, no internet access...

Please help, So frustrated....

0 Kudos
1 Reply
Moderator
Moderator

Re: M14x R2 Won't Connect Wirelessly

Hi Wagglestein,

I‘d suggest that you update the BIOS and Wireless driver in sequence in the link given below and check for issue resolution.

Dell Alienware M14x R2 BIOS                           : http://dell.to/U1bnTS

Dell Alienware M14x R2 Wireless driver      : http://dell.to/Se4Rus

Please let me know if this helps.

0 Kudos