Highlighted
sposthuma
1 Nickel

M15x 260M video card slowdown

I got a brand new M15x with a single 260M last week. All was well, things were running smooth and fast. Until yesterday morning when I noticed games were running a lot slower, and I mean by about 50%. This was after installing another game from Steam that did a DirectX update. So I reinstalled the March09 DirectX runtime as well as the video driver. This didn't help. Many hours later I finally decided to do a clean Windows install from the OEM disk. Imagine my dismay when I finally tried running some benchmarks and the thing is still running slow.

The windows performance index was at 6.8 for both graphics categories (Aero and games) after I first got the machine. Now, after a clean install, the latest DirectX and video drivers, it is at 5.1, which amusingly is slower than my other laptop, a 2 year old Inspiron with a 8600M.  The other numbers are exactly the same so the problem is definitely related to the video card.

I am at a loss here, I was on hold with Dell support for so long that the battery on my phone died so I haven't talked to anyone yet.

If you have a M15x with a 260M, I'd be very curious to know your benchmark numbers, the window performance index, maybe 3DMark and Furmark as well so I can do some comparisons. I am starting to think that maybe the video card is faulty since I don't see how it could be software related after a Windows reinstall. I'd also love to know what version of the video driver you are running.

 

 

0 Kudos
7 Replies
sposthuma
1 Nickel

Re: M15x 260M video card slowdown

I solved this problem by installing the latest NVidia reference drivers, 195.62. There must be some magic combination/order of DirectX and driver installs that brings things back to normal. I just wish it didn't take 6 hours of work to get there!

Now to back it all up before doing anything else!

0 Kudos
Polta
1 Nickel

Re: M15x 260M video card slowdown

Hello sposthuma, I'm deeply interested in your experience because I have the same problem.

I bought an Alienware M17x, Windows Vista Home Pro x64, nVidia 260M last month, having the Win7 upgrade option.

I installed GTA IV still with Windows Vista and it ran great. A week ago I updated to Win7, installed last drivers downloaded from support.dell.com, but the game and several other applications had very low performance. What I did after that is only getting depressed and reinstalling Win7 / Vista 4 or 5 times, searching for any combination that allows me to achieve the original graphics performance. Nothing worked.

Could you please tell me what DirectX / nVidia drivers did you finally install and where did you get them?

Do you have any aditional tip that helps me in this evil trip?

Thanks in advance!

Polta

Alienware M17x || Core2Duo 2.8GHz || nVidia GTX260M

0 Kudos
sposthuma
1 Nickel

Re: M15x 260M video card slowdown

I did a clean install of Windows 7. In your case that means Vista first, then Windows 7. I then installed the August 09 DirectX runtime, followed by the Nvidia notebook drivers for the 200M series. This did the trick. The problem now is keeping it stable. Most games will install some version of the DirectX runtime to ensure all the right dlls are there. You need to ensure this doesn't happen since that is what screwed things up in my case. I now create a restore point before installing any game. I also backed up my DirectX using 'Happy DirectX Uninstall'. I know..the name sounds terribly dodgy but it is legit and can back up and restore your DirectX install.

This morning I installed Warhammer II Dawn of War from Steam. Before I ran it, I went into the install directory and changed the install script so it skipped the DirectX install. The game runs fine and my DirectX install wasn't messed with. This requires some digging around and looking at scripts and such but you can get a long way with Notepad these days. I guess that is what is necessary to keep the machine running optimally.

Good luck and drop me a PM if you have any further questions.

 

0 Kudos
Polta
1 Nickel

Re: M15x 260M video card slowdown

Sposthuma thank you very much for your quick answer. I was just about to follow your steps when I tried one last thing: to install RICOH R5C833 chipset driver. I had already installed nVidia MCP79 chipset driver because the application CPUID told me I had an nVidia chipset. Dell support driver page have both drivers, and I assume you have to install only the driver needed by your chipset, but I'm not still sure about this.

The fact is my performance problems have now disappeared, and in a first approach, they had nothing to do with any DirectX or video drivers. I'm currently running:

WinVista Home Premium x64 (I downgraded from Win7 because the last time my system ran smoothly was with Vista)
Video nVidia Notebook BETA driver (from Dell support page, I was just trying all the drivers I had at hand)
DirectX 11 (the one installed by GTA IV)
RICOH R5C833 chipset driver

My next step is to do a clean install of Win 7 with the correct chipset driver, and check if that was the problem indeed. 

Let's keep in touch, we'll take the best configuration out of this experience.

Thanks again!

Alienware M17x || Core2Duo 2.8GHz || nVidia GTX260M

0 Kudos
Polta
1 Nickel

Re: M15x 260M video card slowdown

After fighting with Windows 7, I realized that my problem had little to do with video / chipset drivers. The problem was a Windows service that froze GTA IV game every time I pressed a key. The solution was:

Windows key + R to open "Run" dialog
Type "msconfig", go to "Services", disable "Windows event log"
Reboot the PC

Hope this helps more people!

Alienware M17x || Core2Duo 2.8GHz || nVidia GTX260M

0 Kudos
tigerwolf7
6 Gallium

Re: M15x 260M video card slowdown

The M15x has an Intel PM55 chipset, NOT an Nvidia one.  You want to keep your video drivers up to date using Nvidia's drivers, not Windows Update's, not Dell's, as all those are outdated.

This system also has a known throttling issue, but it sounds like you're just running into a simple driver issue.

0 Kudos
Polta
1 Nickel

Re: M15x 260M video card slowdown

TigerWolf:

Thanks for the answer! Anyway I don't have a M15x, I have a M17x. Dell support page offers me only RICOH or NVIDIA chipset drivers.

Regarding the NVIDIA 260M video card, I installed latest drivers from NVIDIA page itself.

 

Alienware M17x || Core2Duo 2.8GHz || nVidia GTX260M

0 Kudos