Highlighted
TobiasDahl
1 Nickel

My X51 won't start

I just unboxed my X51 and it doesn't start, what to do?

When I hit the start button there is a side lights quickly just gets lit then back to non lit again. No fans, no nothing except for the on-button that is still lit.

I've tried to reboot it 30 times, unplugged all cables and holding down the start button for 30s about 10 times. Uplugged the power bar and re-plugged, still nothing.

Sent from my Imac (that starts every time).

0 Kudos
3 Replies
TobiasDahl
1 Nickel

RE: My X51 won't start

So I called technical support but no luck there. Could someone from Dell please instruct me what to do. Right now I'm thinking about returning the computer.
0 Kudos
Alienware-Naomi
5 Tungsten

RE: My X51 won't start

Hi!

Please send me a private message with your Service Tag and contact information so I can review your case.

Alienware-Naomi
Dell | Alienware Technical Support Alienware Arena
#IWork4Dell
Opening your case does not void your warranty! Check out Alienware Artificial Intelligence
I can't always reply to PM's, if you need extra assistance visit: YouTube Logo Facebook Logo Twitter Logo

0 Kudos
Kaldeeno
1 Copper

RE: My X51 won't start

Hello, my name is Kalden and I have been building an alienware X51 R2 from a case I bought on ebay. The only thing the case had in it was the motherboard. I have bought an i5 quad core processor, the original graphics card, and put in a solid state drive. I have finally completed building it but when I hit the power button the sides and power button light up and I hear the fan start but within 1 to 2 seconds everything turns off. Please help me I would love to get this thing running.

0 Kudos