Highlighted
thkbrew89
1 Copper

Overclocking the Core i7 930 in the Alienware Aurora

I recently purchased an Alienware Aurora with the new Intel Core i7 930 processor in it. One of the reasons I got this processor is because it is supposed to overclock very well. Needless to say, I was surprised and disappointed to find that the Aurora A04 BIOS does not allow me to disable Intel's Turbo Mode Tech, effectively handicapping its ability to be overclocked. I don't understand the point of building a $2,400 computer for someone with a watercooling system and then not even giving them the option of overclocking their CPU. Does anyone know if there is a different BIOS available that would allow me to disable the Turbo Mode Tech, maybe one not released by Alienware, but by whoever supplies their motherboards? Thanks for any help.

0 Kudos
2 Replies
djkizzle
1 Nickel

Re: Overclocking the Core i7 930 in the Alienware Aurora

Chris from Dell brought up the question on this thread: http://en.community.dell.com/forums/t/19327931.aspx

I just received mine earlier in the week and asked same question.  I figured the processor was newer than the Bios and can only assume something is in the works; plus I figure they already have to do something for the new 980X too.  Maybe Chris is looking into the question and asking Alienware.

Model: Alienware Aurora (AO8)
Command Center: 2.5.51.0
Processor: Intel Core i7 930 3.36GHz
OS: Windows 7 Ultimate 64bit
Hard Drive: 2x1TB Samsung Spinpoint F3 - SATA, 3Gb/s Raid 0
Memory: 6GB Triple-Channel 1333MHz DDR3
Graphic: ATI 2GB GDDR5 Radeon HD 5970
Sound: Integrated 7.1
Mouse: Alienware TactX
Keyboard: Alienware TactX
Optical Drive: 24X CD/DVD burner (DVD+/-RW)

0 Kudos
h2on0
2 Iron

Re: Overclocking the Core i7 930 in the Alienware Aurora

I know that on my 920 if I disable intel speed step tech before I disable turbo mode that disable turbo mode is greyed out and stuck on. So disable turbo mode first before disableing intel speed step tech and cstate(or whatever its Called) So load optimal defaults and see if you can disable turbo mode.

0 Kudos