Highlighted
jabbawhojumps
1 Copper

Problem with Alienware M17x R3's AC adapter, I consequently cannot turn on the my computer.

I was playing a game on my Alienware the other day when it suddenly shut down, apparently from running out of battery life. I looked at my AC adapter's cord and discovered that it was in fact plugged in every way (to the wall outlet, the brick and the computer) yet the blue light on the ring of the cord was no longer on. After replugging in all the cords several times the blue light eventually came back on, though the instant I plugged it back into the laptop the blue light died. So the AC adapter is no longer supplying power to my alienware, so I cannot turn it on or do anything with it. I don't know what caused this problem or how to remedy it. Any help would be greatly appreciated.

0 Kudos
2 Replies

Re: Problem with Alienware M17x R3's AC adapter, I consequently cannot turn on the my computer.

Hi jabbawhojumps,

Try the following steps and see if it helps.

Drain the residual power from the laptop:

  • Disconnect any external peripherals (flash drives, printers, external hard drives) from the computer
  • Then remove the adapter and the battery
  • Press and hold the power button for 10 seconds
  • Reconnect the battery and the adapter
  • Try to restart the computer and check

I believe the light on the AC Adapter goes off after it is connected to the computer. Is that correct?

Check the light on the AC Adapter without plugging it in the computer . Does it light up?

Also, try using an alternate AC Adapter.

Thanks & Regards,
Appu S
#iworkfordell
To know more about Dell’s Product Support, Drivers & Downloads, Orders & Dispatch status -> choose your region USA, India. For Dell Support Videos, click Here.

0 Kudos
9 Rhodium

Re: Problem with Alienware M17x R3's AC adapter, I consequently cannot turn on the my computer.

If the LED on the adapter doesn't come on before you plug in the notebook end, the adapter is faulty.  If it does, and goes out on connection to the notebook, the mainboard is faulty.

0 Kudos