Highlighted
Randical
1 Copper

Qualcomm Atheros Bluetooth Not working? Alienware 17 (2015)

Just updated to Windows 10, so far everything seems fine, even my graphics amplifier is working. Then I realize my mouse and keyboard aren't responding. I've tried others and nothing is working. Device manager claims its working. Can find the drivers on Dell's website as the page won't let me proceed after "system register" is my Dell downloads.

Signed;

Missing my mouse

0 Kudos
2 Replies

RE: Qualcomm Atheros Bluetooth Not working? Alienware 17 (2015)

Hi,

Can you confirm if you have a Qualcomm Killer Wireless 1525 card on the system? If you do, try using this driver. Also, it would be helpful if you can provide a picture of how it’s showing in Device Manger.


Alienware Arena

Alienware-Rodrigo
Dell | Alienware Technical Support
#IWork4Dell
Opening your case does not void your warranty! Check out Alienware Artificial Intelligence
I can't always reply to PM's, if you need extra assistance visit: YouTube Logo Facebook Logo Twitter Logo

0 Kudos
cYpherl0k
1 Copper

RE: Qualcomm Atheros Bluetooth Not working? Alienware 17 (2015)

I tried using that link - it fails to run saying that Windows 10 is not supported when trying to install the driver.

In device manager - it lists as a generic Bluetooth adapter, and with 2 Microsoft Bluetooth Enumerators.

*Edit:
I managed to get my Bluetooth working aging using these drivers:

http://www.dell.com/support/home/us/en/19/Drivers/DriversDetails?driverId=57DFF&fileId=3475111410&osCode=WT64A&productCode=alienware-17-r2&languageCode=EN&categoryId=CM&DCP=DNDTAG

0 Kudos