Highlighted
molozx
1 Nickel

RX 480 with Alienware Graphics Amplifier - windows crash

Jump to solution

Hi Everyone!

My system (Alienware 13 R2 + Amplifier + RX 480) crashes after 1-5min of use.

To be specific I got Gigabyte RX 480 G1 Gaming graphics card with Alien Graphics Amplifier. Installed the latest drivers - all good.

I was able to hook up 3 monitors. Did AMD Eyefinity with two 4K monitors. Even 5K resolution and more. So there are all indications that graphics card works via amplifier.

But after or during benchmarks or light use - constant computer crash and freeze under load and windows 10 blue screen of death
- page fault in nonpaged area
- video tdr failure
- thread stuck in device driver

Tried and didn't help:

- performance profile in power options

- disabling Intel integrated video Card

- Install AMD drivers
http://support.amd.com/en-us/kb-articles/Pages/GPU-5003.aspx

- Install Alienware External Graphics Amplifier Software
http://www.dell.com/support/home/us/en/19/Drivers/DriversDetails?driverId=NX9DF

For instance GTA 5, FarCry Primal, Doom are crashing after 1-5min gameplay. On the other hand the same titles work fine on nvidia laptop card.

Even Windows with no apps running can crash then Rx 480 and Amplifier connected. Nothing similar happens when I use laptop without amplifier.

I even replaced the graphics card (RMA) and the same result.

It appears I'm not alone with this issue - here is another person with similar issue:

https://na.alienwarearena.com/forums/thread/133572/technical-support-1/instability-and-low-fps-while...

I don't want to give up and believe that Alienware Graphics Amplifier and AMD RX 480 so badly behaving - it has to be the way to resolve it.

I would really appreciate any help, tips or suggestion to resolve this issue.

I will be ready to hope on the call and/or screensharing to reproduce and troubleshoot the issue.

1 Solution

Accepted Solutions
molozx
1 Nickel

RE: RX 480 with Alienware Graphics Amplifier - windows crash

Jump to solution

Answering my question.

In my case the issue was with wall power connection. I had laptop, 2 monitors, lamp, electric stand desk - connected to one power outlet.  When I separated Amplifier power outlet and another power connector for laptop, monitors -  system works more stable. But still from time to time reboot - but only at startup before Windows and  not during usage. Problem solved for now.

0 Kudos
3 Replies
brujoMX
1 Copper

RE: RX 480 with Alienware Graphics Amplifier - windows crash

Jump to solution

I have the same problem, system crash after 15 min aprox.

Alienware 17R3, RX 480, Alienware Graphics Amplifier

Please advice

0 Kudos
molozx
1 Nickel

RE: RX 480 with Alienware Graphics Amplifier - windows crash

Jump to solution

Answering my question.

In my case the issue was with wall power connection. I had laptop, 2 monitors, lamp, electric stand desk - connected to one power outlet.  When I separated Amplifier power outlet and another power connector for laptop, monitors -  system works more stable. But still from time to time reboot - but only at startup before Windows and  not during usage. Problem solved for now.

0 Kudos
molozx
1 Nickel

RE: RX 480 with Alienware Graphics Amplifier - windows crash

Jump to solution

Try to separate and improve power outlets. Answered in details in this thread. Please let me know if it helps in your case.

0 Kudos