PillowSword
1 Copper

Strange WiFi problem on my Alineware M11X

I have had my M11X for about a month now and love it with no complaints until yesterday when every 15 minutes my Wifi would kind of stop working.  It would go from providing internet, to "limited access" and do nothing but bridge my computers.  the strange thing is by disconnecting from the network and re connecting it would work fin for another 5-15 minutes.  I know is's not a problem with my router because it's not happening with my other computer or any of my cell phones (6) or tablets (2) so if anyone could help that would be fantastic.  Before posting here I looked through various forums and have not reinstalled windows or messed with any drivers aside from the windows updates that come in from time to time, also it it means anything the wireless module in my laptop is of the intel variety.

0 Kudos
3 Replies
cschnarr
1 Copper

Re: Strange WiFi problem on my Alineware M11X

I have the same issue with my M17X-R2.  I can operate an older Dell for hours and hours without dropping a connection (on the same WIFI network), but the Alienware drops every 15 minutes or so.  I re-installed the drivers, and that seemed to have fixed the problem until a random freeze a couple of days later, then after reboot I had the same problem again.  Re-installing the drivers didn't seem to help this time, and now it's a major annoyance, since it drops my Citrix connection to work every time the network fails.  Any other ideas????

0 Kudos
phil2011
2 Iron

Re: Strange WiFi problem on my Alineware M11X

i had this issue with my m11x r2 and fixed it.  i got a new router, Netgear WNDR3700 dual band gigabit router.  like you it would disconnect anywhere from 5 min to 1 hour.  dell drivers were useless!  went to intel website and got the latest drivers for my card (Intel(R) Centrino(R) Advanced-N 6250 AGN) and all is working better than ever.

0 Kudos
Highlighted
cschnarr
1 Copper

Re: Strange WiFi problem on my Alineware M11X

I started digging through the event viewer, and under "administrative events"  I was getting a "DHCP client" error - unable to renew lease.  I changed to a static IP address and so far haven't dropped.  So now the question is: why is the dhcp client unable to renew its lease when every other computer on the network is able to...

I can live with a static IP address if I have to.  It's less annoying than a dropped connection, I just have to remember that I'm static when I leave the house.

0 Kudos