Highlighted

can we have option to stop disabling onboard dedicated GPU with alienware graphics amplifier

Currently plugging in the alienware graphics amplifier disables the onboard dedicated GPU, im told this is to prevent driver conflicts and also as an idiot proof solution. I would like an option to disable this. This is the first time i've experienced an eGPU setup like this as in the past i would never have to disable onboard dedicated. There are many reasons to not disable onboard dedicated graphics, when it comes to gaming most alienwares are equipped with nvidia GPUs, the nvidia GPU can be used for physx while the eGPU for rendering. I bought the alienware for both work and gaming and my work which involves software development requires GPU coding so being able to use more GPUs at the same time helps too. It was also the cheapest option compared to other laptops with similar spec and having both thunderbolt and another slot for a total of 2 eGPUs is what i bought this laptop for which would give me a total of 3 GPUs + Intel IGP which can run openCL, now i find out that using the graphics amplifier disables onboard dedicated.

Other eGPU solutions like thunderbolt, expresscard and mini PCIe dont do this.

I also checked the setup used, currently the lanes are using x8,x4 x4 setup on my alienware 15 so regardless of whether or not i use the graphics amplifier, the onboard graphics card is always x8. I also see no reason why it cant be hot plugged as servers in the past have had hot pluggable PCIe slots on the motherboard where you just slide the card in, no extra adapter or such. Even sata by itself is hot pluggable too requiring only the electrical to be tweaked for hot plugging. In the past i also used a thinkpad with expresscard which allowed for hotplugging of GPUs, making it appear as a removable vga device.

At least gives us the option to use onboard dedicated as well in bios.

8 Replies

Re: can we have option to stop disabling onboard dedicated GPU with alienware graphics amplifier

Hallo systemerrormessage.

i'm trying to understand how the AGA works and i have one Question. are you sure that the connected GPU via AGA is connected with only 4 Lanes? i always thought it would be atleast 8 Lanes.

Area 51-R2, BIOS A10, i7-5820K @ 4.0 GHz, Crucial Tactical 64 GB @ 2666 MHz, Titan X(P),

Samsung 960 Pro M2 SSD, Crucial MX300 SSD, 1500W Dell PSU, Win10 Home, Yoda USB Guard Smiley Happy

0 Kudos

Re: can we have option to stop disabling onboard dedicated GPU with alienware graphics amplifier

Both GPUz and the cable used only supports 4 PCIe lanes. so dell could've designed it not to disable onboard dedicated graphics and have enough lanes for 2 of them and thunderbolt.

Tesla1856
6 Thallium

Re: can we have option to stop disabling onboard dedicated GPU with alienware graphics amplifier

Possibly.
 
What comes to mind for me is that the AGA solution was thought-up 2-3 years ago. Doesn't sound like a long time, but in "computer technology years" that can be a long time (things move fast). 
 
You know, people dis Apple for changing things, moving on, and dropping Legacy technology. But in this day-and-age, it's actually pretty smart ... IMHO.


Registered Microsoft Partner and Apple Developer
- Gaming when I'm not programming.
- I answer questions here, but I'm not a Dell employee.
- Consider giving posts you like a "thumbs-up"
- Posting models-numbers and software versions speeds trouble-shooting.
- Click "Accept as Solution" button on any post that answers your question best.

Re: can we have option to stop disabling onboard dedicated GPU with alienware graphics amplifier

Holy Cow. yes, you're right about that.

you know Guys, i think the AGA Idea is actually really good, but there is definitely Room left for Improvement.

@ Tesla1856.

i agree. at some Point it's Time to leave old Standards behind.

Area 51-R2, BIOS A10, i7-5820K @ 4.0 GHz, Crucial Tactical 64 GB @ 2666 MHz, Titan X(P),

Samsung 960 Pro M2 SSD, Crucial MX300 SSD, 1500W Dell PSU, Win10 Home, Yoda USB Guard Smiley Happy

0 Kudos
Tesla1856
6 Thallium

Re: can we have option to stop disabling onboard dedicated GPU with alienware graphics amplifier

SystemErrorMessage wrote:

Both GPUz and the cable used only supports 4 PCIe lanes.

Ok, if you say so.
 
But what version? Because 4x v3.0-PCIe lanes is same throughput as 8x v2.0-PCIe lanes (which is pretty fast). 


Registered Microsoft Partner and Apple Developer
- Gaming when I'm not programming.
- I answer questions here, but I'm not a Dell employee.
- Consider giving posts you like a "thumbs-up"
- Posting models-numbers and software versions speeds trouble-shooting.
- Click "Accept as Solution" button on any post that answers your question best.
0 Kudos

Re: can we have option to stop disabling onboard dedicated GPU with alienware graphics amplifier

yes its version 3, it uses the CPU's PCIe lane which is faster than current thunderbolt. Ever since ivybridge mainstream CPUs have 16 PCIe v3 lanes, which can be configured as x16, x8 +x8, x8 +x4 +x4 so the CPU itself supports a maximum of 3 devices on its PCIe lanes. It doesnt matter how many lanes the device supports or what version so if you use a pcie 2.0 device it will get 4 lanes at pci e 2.0.

I havent tested but i do know non GPUs can be used such as 10Gb/s NICs for example as they require 4 pci e v2 lanes.

0 Kudos
Tesla1856
6 Thallium

Re: can we have option to stop disabling onboard dedicated GPU with alienware graphics amplifier

SystemErrorMessage wrote:

It doesnt matter how many lanes the device supports or what version so if you use a pcie 2.0 device it will get 4 lanes at pci e 2.0.

 

Good point. Yes, lowest common denominator. I wasn't sure if AGA was PCIe-v3.0 or not.


Registered Microsoft Partner and Apple Developer
- Gaming when I'm not programming.
- I answer questions here, but I'm not a Dell employee.
- Consider giving posts you like a "thumbs-up"
- Posting models-numbers and software versions speeds trouble-shooting.
- Click "Accept as Solution" button on any post that answers your question best.
0 Kudos
jace888au
1 Nickel

Re: can we have option to stop disabling onboard dedicated GPU with alienware graphics amplifier

Funnily enough my AW15r3 with a Gsync 60hz IPS panel has this behaviour whereby both the internal (GTX 1060) and external AGA (GTX 1080Ti) remain connected/active even when using the AGA. This means that I can actually elect to use both GPUs simultaneously when working on different tasks/apps, or even mining!

On my new AW13r3 with a GTX 1060 and OLED panel, plugging in the AGA (with the 1080Ti) disables the internal GPU (1060) entirely and it is not visible in Device Manager . i.e. different behaviour to my AW15r3.

0 Kudos