celloguy15
1 Copper

15 R2, UHD stuck pixels

I have an Alienware 15 R2 with a 4k UHD display. Within the past 6 months or so, there has been an issue with my screen that pops up every now and then when I open my laptop. "Stuck pixels" is the best that I can describe it as, even though I know this is not the correct technical description. As shown in the pictures, there are thick lines of pixels that flicker between showing the current picture and what the pixels are "stuck" on (in one case for instance is showed what was on the desktop). The problem slowly fades away after a couple hours on. Also, the problem does not show up on an external display. I haven't found anything online like this, and was wondering if this is a serious problem I need to fix or if there's an easy solution to this. Thanks.

IMG_20190210_212014.jpgIMG_20190210_212040.jpg

Tags (2)
0 Kudos
2 Replies
Moderator
Moderator

Re: 15 R2, UHD stuck pixels

Hi @celloguy15 

This could go from a loose wire or dirty connector, to an LCD replacement.

Alienware Arena

Alienware-Eimy
Dell | Alienware Technical Support
#IWork4Dell
Opening your case does not void your warranty! Check out Alienware Artificial Intelligence
I can't always reply to PM's, if you need extra assistance visit: YouTube Logo Facebook Logo Twitter Logo

0 Kudos
Highlighted
celloguy15
1 Copper

Re: 15 R2, UHD stuck pixels

A loose or dirty connection would make some sense since I carry it around a decent amount. I'll check it out sometime if it gets worse. Thanks

0 Kudos