Alcasczar
1 Copper

17 R2, Bios A10 update failed

I am helping my sister who has a Alienware 17 R2 laptop,  she ran an update to the bios A10 but the process made the screen go black and now when it boots up it displays nothing on screen.  I hooked up an external monitor the HDMI port and also get nothing there too.    The RGB lighting on is still functional so I am at least hopeful this isn't bricked but it sure is acting like it  Smiley Sad

I looked up some specifics but it appears I keep running into dead-ends.   Can anyone provide any help?    I don't think it has a recovery option 1 available so I've been attempting to create bootable flash drive but the system won't recognize it,  it just stays there lights changing colors and no display so it's hard to tell what it's doing.

When the colors change it looks like it turns off then back on again.      Any assistance would be fantastic.

 

Edit:  Forgot to mention,  I've followed some guides online here.  Opened up the back and disconnected the battery cable from the board.   Held power button down for 30 seconds,  reconnected everything,   powered on with ac power holding FN key but still nothing.    Also tried holding CTRL+ESCAPE but still nothing,.

2 Replies

Re: 17 R2 Bios A10 update failed.

Hi, 

Please send us your Service Tag in a PM, so we can review your case and get back to you. 


Alienware Arena

Alienware-Rodrigo
Dell | Alienware Technical Support
#IWork4Dell
Opening your case does not void your warranty! Check out Alienware Artificial Intelligence
I can't always reply to PM's, if you need extra assistance visit: YouTube Logo Facebook Logo Twitter Logo

0 Kudos
Highlighted
pbarrera23
1 Copper

Re: 17 R2 Bios A10 update failed.

Hello this happen to mine as well. I was using dell update software and there was a new update for bios dated october 2019. Update did not finish and the computer hung for sometime. After nothing is happening in more than 15 mins. I turned off the laptop by the power button. However after that this same problem occurs. Please help. I tried the same as this guy but to no avail.

my laptop is Alienware 17 R2.

service tag <Service Tag removed>

0 Kudos