equipped2000
1 Nickel

17 R5, FX lighting keeps locking up

Alienware 17 R5 FX lighting keeps locking up... on a non existant colour scheme (yellow)...

I've tried several times now to completely remove Command Center and reinstall to fix this problem but nothing I do seems to rectify it.

After deleting everything (I followed the instructions dell provide, plus registry, temp, program data etc...), I reinstall, launch any game, no profiles or games are set up in command center, no lighting profiles made, no macros etc, its just the base installation, the laptop immediately changes to a "yellow" profile that doesn't even exist.

Now I have checked all through the .json files where profiles are stored (In: C:\Users\YOUR_USER_NAME\AppData\Local\Packages\DellInc.AlienwareCommandCenter_htrsf667h5kn2\LocalState\FX ).... and there is no profile that matches this "yellow" scheme

Once this "yellow" scheme enables, it then locks up the FX capabilities untill I shutdown and restart..... Trying to change profiles in Command Center does nothing.... you cant even go to dark mode to disable backlighting, you have to shut down.

Then, if you make a FX profile, add a game and assign the game to that profile, you would then expect the FX profile to enable that FX colour scheme when lanuched...

Nope.

The phantom yellow scheme appears again.... and you have to shut down to get rid of it.

The only saving grace is that until you launch a game, you can switch FX profiles, they seem to behave normally... so it is NOT a hardware issue as the hardware does respond normally until any game is launched.

I even tried editing the .json files (and removed references to it in FXProfileMaster.json, MasterProfile.json ) to remove the system default profile that Command Center applies, by replacing it with an FX profile I created, to see if it was "the default profile that the software installs" that caused the "yellow" profile.... but even that didn't get rid of it.... and ... nope.... this phantom yellow keeps appearing....

So having hacked the .json files, purged every bit of command center installation I could find, reinstalled numerous times, removed any hint of this from the registry and closely followed Dell's guide to uninstalling Command Center.... I'm now at a loss as to what to do next....

I've gone beyond what Dell respond to, they didn't even respond to other posts asking where the profiles are stored.... I had to figure that one out (I responded to those who asked in other threads)....

So I am wondering, am I alone in this problem, or are any of you also getting this weird cr4p with FX profiles ??

Any thoughts on a fix? lmk



7 Replies
Dontpanicau
1 Copper

Re: Alienware 17 R5 FX lighting keeps locking up...

I have only recently gotten my R5 though I seem to have this problem aswell. Though it is localized to one game. World of Tanks. The edges will "countdown" in white in the initial game timer and the board goes yellow. There are no game profiles for in the command center and was going to create one tonight to hopefully fix this issue. I'm hoping that's the extent of it but you are not alone it would seem.
0 Kudos
RadiumOne
1 Nickel

Re: Alienware 17 R5 FX lighting keeps locking up...

My R5's lights went berserk after I launched Civilization VI for the first time. Initially, they'd revert to default blue and start flickering and only rebooting would fix them. Then they just got stuck on the Spectrum setting and now that's just what they permanently are. Nothing I've done, including completely removing and re-installing AWCC has fixed them. The theme doesn't change, rebooting doesn't help, the FN+F12 shortcut doesn't do anything, nothing works. It's like Spectrum is the only setting. This is obviously an issue endemic to the 17 R5. I hope Alienware rolls out a fix soon.

0 Kudos
Tesla1856
6 Thallium

Re: Alienware 17 R5 FX lighting keeps locking up...

Try a clean-install of AWCC v5.2.20 .

https://www.dell.com/support/home/us/en/19/drivers/DriversDetails?productCode=alienware-17-r5&driver...

Try not to use the "Update from AWCC Server on Startup" thing.

In Device Manager / System Devices ... make sure there is only ONE "AWCC Driver" showing. DM should be free of errors.

The option in AWCC v4.x was "Enable Third-Party AlienFX Access" but I don't see that in this v5.2.x version. Nor does it have a SysTray icon.


Registered Microsoft Partner and Apple Developer
- Like many of you, I can appreciate a good game-engine.
- I answer questions here, but I'm not a Dell employee.
- Consider giving posts you like a "thumbs-up"
- Posting models-numbers and software versions speeds trouble-shooting.
- Click "Accept as Solution" button on any post that answers your question best.
0 Kudos
equipped2000
1 Nickel

Re: Alienware 17 R5 FX lighting keeps locking up...

I read another persons thread about their issues with the FX lighting. They suggested this as a fix to stop the auto game recongnition part happening.

____________________________________

So for anyone in this situation, this is what I did for the time being. Your mileage may vary, but this worked for me to prevent the locked-up colors:

* Uninstall Alienware Command Center

* Look under C:\Windows\System32. Rename the file "LightFX.dll" to "LightFX.dll.old"

* Shut down (NOT simply restart) * Turn your laptop back on At this point, the system will boot back up, showing the "default" AlienFX colors (solid light blue).

Running AlienFX-compatible games will no longer break, as they look for a loaded LightFX.dll.

____________________________________

Shutting down (not rebooting) is usually also the way to clear the initial problem, but I've also been haunted by the persistant issue. So I've just done a windows reinstall to purge all problems, reinstalled every driver and update from the Dell site. If it happens again I'll just do the above and be done with it until whoever is responsible get their software fixed, or removes this buggy feature all together.

0 Kudos
equipped2000
1 Nickel

Re: Alienware 17 R5 FX lighting keeps locking up...

Thanks for the reply,

What is the "Update from AWCC Server on Startup" thing you mention? It's not an option in AWCC afaik?

The Enable Third-Party AlienFX Access was removed in 5.xx sadly. And 4.xx checks hardware and wont allow installation.

Other threads allude to dodgy 3rd party implementation and Dell's reluctance to facilitate any sort of adherence to a standard that makes this work. So in reality, it has been left to the end user to choose between disabling the feature with a dll-disable hack or live with the dodgy software upon game launch.

My preference, should my latest clean reinstall fail, will be to do the dll rename I posted from another owner suffing this joke of a problem, and just live with the FX software being at my sole command and not reacting to game launches...

Maybe Dell, in their enlightenment, may one day provide an option to disable this feature in their software, so we actually get the choice of whether we want the feature on or not.

Wont hold my breath tho.... !!

0 Kudos
orion_2280
1 Copper

Re: Alienware 17 R5 FX lighting keeps locking up...

Hello im a bit late to this party, but i just got an alienware m15 this past Wednesday, i was having the issues with world of tanks. I didn't know the game was taking control of lights, and getting stuck on yellow. I tired the uninstall, but command center gave me my lights back, but now no thermal controls. tried another fresh install. no good, after 4 hours on the phone with alienware, and a full system restore because, command center would never completely uninstall, even when alienware tech tried it. all was finally back to normal thermals, and lights. so i go back to playing world of tanks, bam lights back yellow no control in command center. so what i have found seems to work some how, is to power off the laptop completely. close lid, i noticed powered off the rear alien head is still glowing yellow. so i unplugged the ac adapter from the computer, stayed yellow for a few seconds, then turned red and finally went off. after restarting, it somehow fixed itself without having to try the dreaded uninstall again.

what i think is happening is with that light still glowing yellow, and unplugged from the wall, its effectively doing a power drain, sort of. and maybe clearing out whatever memory or cache that is saving the world of tanks lighting profile. yes 3rd party disable would be great because i do not wanna see my lights flashing anyways. for me though sticking with my method for now, cuz i do not wanna do a full restore when command center wont leave my pc. 

also i have notice no dell person or moderator has responded here so issue will likely go unresolved for quite sometime

0 Kudos
DougalAW
1 Nickel

Re: Alienware 17 R5 FX lighting keeps locking up...

It's very disappointing that we've had no information back from Dell/Alienware in regards to this issue. 

There was a post where it was mentioned one of the recent AWCC versions could fail to flash the FX hardware properly and cause issues, and that an update was due out to rectify this. 

It's anyone's guess whether this will help with regards to how the lights are performing in some game titles.

I too would just prefer to be able to set my own scheme and disable 3rd party apps/games from trying to control the lighting. I don't understand why a feature like that would be removed as it's just opening things up to problems and leaving us the consumers in the middle of it all with no way to resolve it. 

0 Kudos