Hurricane86
Bronze

AW15R3 F5 Key triggered when USB devices are (un)plugged

I have an interesting issue which seems to have followed me from my old AW15R2 to my new AW15R3. 

I am running the AW15R3 with the 7820/1070 combo connected to the AWGA with a 1080SC from EVGA. 
All drivers are latest, windows is up to date. 

Whenever I plug in or remove a USB device all of the lights on the AW will flicker, go off and then come back on as if the controller for them has crashed and recovered. During this time, the F5 key is triggered numerous times. This manifests as spamming refresh if I have an active browser window, or if I am in a terminal session it manifests as several instances of the ~ character being sent to the command line (same behavior if I press F5 while at a shell terminal).

I previously experienced this behavior on my R2 and this issue was such an annoyance that it was a major factor for me to upgrade in the first place. 

Has anyone else experienced similar behavior with their AW? My working theory is that it has something to do with the macro controller on the built in keyboard crashing and re-initializing whenever a USB device is plugged. 


0 Kudos
7 Replies

Re: AW15R3 F5 Key triggered when USB devices are (un)plugged

Hello,

Just to confirm, have you experienced this problem with the AWGA unplugged?

Thanks

Alienware Arena

Alienware-Rodrigo
Dell | Alienware Technical Support
#IWork4Dell
Opening your case does not void your warranty! Check out Alienware Artificial Intelligence
I can't always reply to PM's, if you need extra assistance visit: YouTube Logo Facebook Logo Twitter Logo

0 Kudos
Hurricane86
Bronze

Re: AW15R3 F5 Key triggered when USB devices are (un)plugged

I am fairly certain I have indeed experienced it while undocked from the AWGA, as I take the machine to my friends house quite often. When I get home from work I will undock it and test to be sure. 

0 Kudos

Re: AW15R3 F5 Key triggered when USB devices are (un)plugged

Ok, thank you. 

Alienware Arena

Alienware-Rodrigo
Dell | Alienware Technical Support
#IWork4Dell
Opening your case does not void your warranty! Check out Alienware Artificial Intelligence
I can't always reply to PM's, if you need extra assistance visit: YouTube Logo Facebook Logo Twitter Logo

0 Kudos
Hurricane86
Bronze

Re: AW15R3 F5 Key triggered when USB devices are (un)plugged

So at the moment I am running the machine detached from the AWGA and while I DO still see the lighting effects turn themselves off and then back on when I plug or unplug a USB device, it does not appear to be firing off the F5 keys. 

However as I am away from home it is possibly also worth noting that there are other devices that typically remain connected to the various USB ports that I do not have access to right now. 

1. My Razer Black Widow Chroma keyboard which connects through the USB ports on the AWGA
2. A Samsung T5 External SSD (via the USB Type C port) 
3. A WD passport 2TB External disk (Via a USB 3.0 Hub plugged into the right hand side USB type A port)
4. A Corsair Scimitar Mouse connected through the Left hand side USB Type A port
5. A Logitech Webcam (the aforementioned Hub) 
6. An Xbox One controller (The hub) 

There are other devices that Are often swapped on and off the hub, but when I am docked the above are the only "Constants" I most often notice the behavior when plugging in my yubikey to authenticate with E-mail, or when plugging in a USB Thumb Drive. Both of these tasks are performed with the hub; but I hesitate to blame the hub itself, as unplugging the scimitar from the built in port and plugging it back in can also trigger the behavior. 

I will retest from home during the day tomorrow with various configurations of plugged/unplugged devices and see if I can narrow it down, then report back again in case this ever happens to someone else. 

Are there any known compatibility problems with any of the devices I mentioned? 

0 Kudos
Hurricane86
Bronze

Re: AW15R3 F5 Key triggered when USB devices are (un)plugged

As it turns out with the machine plugged into the AWGA and my keyboard plugged into the AWGA, anything I plug into any USB port is enough to trigger the machine into a seizure.  I actually ended up locked out of logging into this website this morning because of all the F5 key strokes refreshing the page too fast, I guess the web server thought it had to protect itself. 

Is this a known issue with the AWGA or have I found special new kind of annoying bug? ^_^ 

0 Kudos

Re: AW15R3 F5 Key triggered when USB devices are (un)plugged

Hi,

I have never heard about this particular issue before, I suppose it could be a bug like you said. Send me your Service Tag in a PM, so we can look further into it. 

Alienware Arena

Alienware-Rodrigo
Dell | Alienware Technical Support
#IWork4Dell
Opening your case does not void your warranty! Check out Alienware Artificial Intelligence
I can't always reply to PM's, if you need extra assistance visit: YouTube Logo Facebook Logo Twitter Logo

0 Kudos
DMGZD
Copper

Re: AW15R3 F5 Key triggered when USB devices are (un)plugged

My alienware 17 R4 does the same thing anytime a usb device is plugged in or unplugged it refreshes whatever web page i have up. It does this regardless of the browser. This is so annoying did you ever get a solution or find out why this happens? 

0 Kudos