pr1ntf
Copper

Alienware 15 R3(2017) freezes BIOS after splash

    Hello, today at about 2 AM I just finished a game session on my laptop(running windows to go of a external HDD). After I power off the machine is magically started up and began updating the bios, fans full throttle, scaring every living piece out of me. After the update was done I went to bed and this morning when I wanted to boot into Fedora Linux to continue my work, BIOS just freezes after splash. The progress bar is stuck at 100% but doesn't boot the drives. It can enter BIOS setup or boot menu, but  still doesn't boot the drives. It just freezes. I'm pretty mad about it considering that I didn't even get notified about the update. 

    Later this day after some research I found no solution so I just looked for another update for the BIOS. I tried to install it and after I booted up into the Windows to go drive again, launched the Alienware Update center, the update was still there like it wasn't installed at all. 

    Please help me out, I really need a long term solution, not pushing F12 every time before the progress bar reaches the end.

 

    Thanks in advance,

                                     Vlad

0 Kudos