SH3RIFFO
Bronze

BIOS update (v1.4.4) for Alienware 15R2/17R3 - Has Broken Graphics Amplifier Functionality

Hello,

To whom this may concern.

I had an Alienware Graphics Amplifier connected to my Alienware R2 laptop, which was also connected to a GTX 1080 Ti graphics card, and a MG28UQ Asus Gaming Monitor. Now only the laptop works on its own, the rest dysfunctional. Why?

Ever since I installed the new urgent BIOS update, my Alienware Laptop has started showing many problems and issues. Such inconveniences of which I still cannot fix, even with the help of a customer support agent. 

These are a few examples of problems that I have started to encounter:

1) It has become very slow, unresponsive, and laggy.
2) Connecting an Amplifier only makes it worse, ironically amplifying the DECREASE in performance and responsiveness.
3) In addition, if the Amplifier has a connected Monitor, then the system completely goes haywire, and ends with a black non-responsive screen.
4) The PC refuses to shutdown, leaving a black screen, but the LED lights of logo and keyboard remain on, as well as a hot system still running in the background.
5) My Device Manager has also identified and found a problem with a driver. (Trusted Platfrom Module 2.0)
6) Games no longer run and would crash upon launch, get stuck, and/or activate a BSOD.

I honestly have reasons to believe that the latest BIOS update has severed functionality of the Amplifier.
The graphics card within is no longer in use, and the monitor does not respond or behave correctly. 

I wanted to revert back to the previous version of (v1.3.12), in which everything was working fine as intended before, but was denied by the setup wizard and also told by an agent of customer support that I could not.

If this latest BIOS was as urgent as it's described, then please fix the amplifier issues as well as the drives, and release a newer optimized version. This has put everything from my rig setup of Alienware tech to halt, and I am very displeased.

As requested by the agent I spoke to, here's the information you might need:

Operating System: Windows 10 (Version 10.0.16299 Build 16299)
System Model: Alienware 15 R2
External GPU: ASUS GTX 1080 Ti
BIOS Version/Date: Alienware 1.4.4, 08-Jan-2018
Alienware Graphics Amplifier: 452-BBRG (Reg Model:  Z01G | Reg Type No.: Z01G001)

 
In addition, here's information I've copied and pasted regarding the Driver issues that this BIOS update has caused:
 
Device Encryption Support: "Reasons for failed automatic device encryption: TPM is not usable, PCR7 binding is not supported, Hardware Security Test Interface failed and the device is not InstantGo, Un-allowed DMA-capable bus/device(s) detected, Disabled by policy, TPM is not usable"
Device Manager problem: "Trusted Platfrom Module 2.0 has a driver problem"
 
Thank you for your time and understanding, I look forward to seeing your accommodation in progress and expect a fix as soon as possible.
 
Sincerely, an Alienware member,
 
SH3RIFFO
Sharif Khaled
27 Replies
ilicitano
Bronze

Re: BIOS update (v1.4.4) for Alienware 15R2/17R3 - Has Broken Graphics Amplifier Functionality

Hi,

I have suffered all of your issues, except amplifier one (I don't have it) but after installing previous bios version (1.3.12) the only issue remaining is the shutdown. My laptop (Alienware 15 r2) is not power off completely, lights stay on.

At least all other issues were resolved.

0 Kudos
SH3RIFFO
Bronze

Re: BIOS update (v1.4.4) for Alienware 15R2/17R3 - Has Broken Graphics Amplifier Functionality

Hello ilicitano,

How did you manage to install the previous version? Wasn't it protected?

Also, as I've mentioned before, the customer support agent told me over the phone that it's best not to revert back because it might hurt/fry the motherboard. Have you experience any new problems in doing so?

I know that 17R3 users have been experiencing a different problem where they simply cannot boot up their systems at all. Seems like this update has messed with both ends.

I really hope for a fix soon.

 

Sharif Khaled
0 Kudos
Moderator
Moderator

Re: BIOS update (v1.4.4) for Alienware 15R2/17R3 - Has Broken Graphics Amplifier Functionality

Hi @SH3RIFFO,

Run the latest BIOS version form the website, it has the same version number, but as you can see it was updated on February 6. The one that you have is the one from "BIOS Version/Date: Alienware 1.4.4, 08-Jan-2018"

Let me know how it goes!

Alienware Arena

Alienware-Eimy
Dell | Alienware Technical Support
#IWork4Dell
Opening your case does not void your warranty! Check out Alienware Artificial Intelligence
I can't always reply to PM's, if you need extra assistance visit: YouTube Logo Facebook Logo Twitter Logo

0 Kudos
SH3RIFFO
Bronze

Re: BIOS update (v1.4.4) for Alienware 15R2/17R3 - Has Broken Graphics Amplifier Functionality

That is literally the very same download file that I installed yesterday.

It is quite common for Dell's driver pages to be inaccurate in detail. 

I did not get the notification to update, nor was the download available until the 6th of February, which is what I and many others have installed. The January 8th details are only visible from the BIOS installation itself, as well as seen from System Information.

Sharif Khaled
0 Kudos
Moderator
Moderator

Re: BIOS update (v1.4.4) for Alienware 15R2/17R3 - Has Broken Graphics Amplifier Functionality

Please send me a private message with your Service Tag. 

Alienware Arena

Alienware-Eimy
Dell | Alienware Technical Support
#IWork4Dell
Opening your case does not void your warranty! Check out Alienware Artificial Intelligence
I can't always reply to PM's, if you need extra assistance visit: YouTube Logo Facebook Logo Twitter Logo

0 Kudos
ilicitano
Bronze

Re: BIOS update (v1.4.4) for Alienware 15R2/17R3 - Has Broken Graphics Amplifier Functionality

Hi @SH3RIFFO I followed this manual https://www.dell.com/community/Alienware-laptops/BIOS-update-v1-4-4-for-Alienware-15R2-17R3-Has-Brok...

You can install previous bios using that method, any other way is not possible because of the bios protection. As I told you before the only issue I'm experiencing now is the shutdown. I need to hold the power button in order to power off the machine completely.

0 Kudos
l.herrera
Bronze

Re: BIOS update (v1.4.4) for Alienware 15R2/17R3 - Has Broken Graphics Amplifier Functionality

Hi,

Today I downloaded and updated (12-FEB-18) to BIOS V1.4.4. As a result, the laptop will stay like 1-2 min on the Alienware screen before loading Windows, and also it refuses to shutdown (just like you guys have explained) leaving a black screen and LED lights of the MACRO keys and power button on.

Also, I've noticed a little bit of lag, for instances the mouse on the screen will freeze for no reason.

I really hope that we can get a fix to all these issues soon as I use this computer for work!!

Operating System: Windows 10 (Version 10.0.16299 Build 16299)
System Model: Alienware 15 R2
BIOS Version/Date: Alienware 1.4.4, 06-Feb-2018

 

Luis

Smythius
Bronze

Re: BIOS update (v1.4.4) for Alienware 15R2/17R3 - Has Broken Graphics Amplifier Functionality

I also have an Alienware 15R2 and have yet to apply the new BIOS update. I am running Windows 7 and am curious if the rest of you are all on Windows 10? Currently my system runs well but there is no support for USB 3.0 and so my system reverts to a default of USB 1.0 speed. I was hoping this new BIOS update might finally support USB 3.0 for windows 7. Any information would be greatly appreciated.

0 Kudos
ilicitano
Bronze

Re: BIOS update (v1.4.4) for Alienware 15R2/17R3 - Has Broken Graphics Amplifier Functionality

I would recommend you not to install bios v1.4.4 especially if you have an Alienware 15 r2. All the people are having serious problems with bios 1.4.4