ilicitano
Bronze

Re: BIOS update (v1.4.4) for Alienware 15R2/17R3 - Has Broken Graphics Amplifier Functionality

I have an Alienware 15 r2 and after updating to bios 1.4.4 the system became unstable, windows 10 takes about 2-3 minutes to load (instead of 10 seconds), power off option doesn't work properly and there is a device that display a warning.

At the end I returned to bios 1.3.12 but not all issues were fixed. The shutdown option is not working properly.

0 Kudos
l.herrera
Bronze

Re: BIOS update (v1.4.4) for Alienware 15R2/17R3 - Has Broken Graphics Amplifier Functionality

Hi @Alienware-Eimy, are there any update about these issues with the BIOS v1.4.4?

 

Thanks in advance for your prompt reply,

Luis

0 Kudos

Re: BIOS update (v1.4.4) for Alienware 15R2/17R3 - Has Broken Graphics Amplifier Functionality

Hi,

I have a 15R2 and the February 6 update is not good either. In fact this update gave me problems. First of all booting the PC takes around 2-3 minutes. Shutting down computer doesn't completely turn off the computer. The keyboard and power button light keep on. And same issue when the computer goes to sleep. I have to completely turn off the computer by long pressing the power button. I cannot say anything about the amplifier because i don't have one. This is very frustrating and is very obstructing for day to day use.

Can we please get a fix this.

Thanks!

0 Kudos
Moderator
Moderator

Re: BIOS update (v1.4.4) for Alienware 15R2/17R3 - Has Broken Graphics Amplifier Functionality

Hi @strontium-alien,

Send me a PM with the Service Tag so I can assist you further. 

Alienware Arena

Alienware-Eimy
Dell | Alienware Technical Support
#IWork4Dell
Opening your case does not void your warranty! Check out Alienware Artificial Intelligence
I can't always reply to PM's, if you need extra assistance visit: YouTube Logo Facebook Logo Twitter Logo

0 Kudos

Re: BIOS update (v1.4.4) for Alienware 15R2/17R3 - Has Broken Graphics Amplifier Functionality

Has there been any solution? I updated to Bios 1.4.4 and due to the issues that to revert back to the 1.3.12, but now my 15 r2 refuses to shut down as well. I have to force shut down. 

0 Kudos
Darkclaw26
Copper

Re: BIOS update (v1.4.4) for Alienware 15R2/17R3 - Has Broken Graphics Amplifier Functionality

I’m experiencing all these problems now, has there been a patch yet or a way to fix it. I use the computer daily and this makes that a pain. I have an Alienware 15 r2
0 Kudos

Re: BIOS update (v1.4.4) for Alienware 15R2/17R3 - Has Broken Graphics Amplifier Functionality

Hello @Alienware-Eimy, I am having all the same problems that everyone else is having and was wondering if there is any solution that you can help me with.

Re: BIOS update (v1.4.4) for Alienware 15R2/17R3 - Has Broken Graphics Amplifier Functionality

Hi @Alienware-Eimy,

It's been a while since this issue started. Do you have any updates for us? You offered me to send in my device for repairs then when i agreed you asked me to wait for bios update. It's been months without any update.

I love my laptop and would really like it to work properly. Please provide some information.

Thanks.

HouseofCat
Bronze

Re: BIOS update (v1.4.4) for Alienware 15R2/17R3 - Has Broke

Bump to remind Dell this BIOS is still broken.

Benjii519
Copper

Re: BIOS update (v1.4.4) for Alienware 15R2/17R3 - Has Broke

Given that its been 6 months since this BIOS update broke introduced these issue to my laptop, I am starting to look for a new one. You can bet I'm having second thoughts about Alienware, if they can break a high end device with an update without addressing it..

0 Kudos