Alienware

2 Bronze

Installed Windows 10 today and now my Realtek PCIE Cardreader not recognize

I have a Dell Alienware Service Tab <Service tag removed> (yes it is expired).  I had Wins 7 but updated to Wins 10 and now my Realtek PCIE Cardreader won’t recognize my Micro SD card since then.  Yes I did update all drivers (used Support Assist to download) as well as many other suggestions but it won’t recognize the SD card.  (Yes I tried different adapters for my Micro SD Card and won’t recognize).  My USB flash drive is fine and show the location.  It is telling me that “Windows did not start this device driver because it can cause your computer to become unstable” Under C:\windows\system 32\drivers\RTSPSTOR.sys has a circle with a red line through it.  I have tried many options that I can find and nothing will allow Windows 10 to show the cardreader drive location.  Please can you help me??  (Cynthia)

Replies (7)
6 Indium

It appears that the driver you have may be an older version. Have you tried the version that is listed here? It does state in the first sentence that it is compatible with Alienware systems.




-Forum Member since 2016
-I do not work for Dell
-A user helping other users
-If you like an answer please click on thumbs up
-If a reply is a solution to your problem please click on Accept as Solution
Gaming on a home built with MSI B-450M Pro-VDH Max budget build with an Athlon 3000G
Real work on a Latitude E5430

Hi

Yes,there must be a driver for Win10 installed. You can also try to use some driver update tools checking all components in your laptop such as Iobit Booster Driver or Driver Magician.

 

Yes I already updated the drivers from DELL and such and still doesn't want to work in Windows 10.

Only thing is Windows 10 isn't allowing the update device drivers to reflect the update in device manager, I tried so many new drivers from DELL and Realtek and looking back at Device Manager properties screen that it doesn't change from 2013 drivers and still gives the same message.  I did uninstall the device and ran the drivers again but no change for me.  I did a restart on the laptop and no change. 

 

I am about ready to just go back to Windows 7 and take my chances in the real world because everything worked before.  My Micro SD card adapter worked, my cell phone could bluetooth photos to the laptop fine and my pictures were easy to view, display unless the arrange of Windows 10 layout.  It tells me I have 10 days to revert back since I see I have a file Windows, old in my folders.  I have been trying for 2 days to make the SD card work, my cell phone says CONNECTED/PAIR but I can only send a photo to the cell but can't send a photo from my cell to the laptop (SAYS NOT SENT)(talks about made need to be configure to accept connections - whatever that means???).  Everything worked just fine before Windows 10.  Makes me so sad that I upgraded.

I really appreciate your help greatly.  Since I have so much trouble with Windows 10 causing conflict with various parts of my laptop I return back to Windows 7 and now everything is working like before, my SD card slot, my bluetooth photos from cell to laptop, my Outlook sending receiving email, my Firefox-YouTube sound is working. 

 

My version of the Realtex card is 6.2.920028134 (2012 year) it shows and nothing I do can update the driver to the link you attached.  It tells me you have the best driver that is available.

 

Cynthia

2 Bronze

Same problem, but I was able to find this driver on the Realtek site, even though neither Dell nor Windows knew about it. There is no longer a device error listed in Windows 10 64-bit 1909 Device Manager.

https://www.realtek.com/en/component/zoo/category/card-reader-solutions-card-reader-controllers-soft...

I just downloaded the driver and then extracted it into a subdirectory.

Then I went to Device Manager Memory technology devices >> Realtek PCIE CardReader >> Driver >> Update Driver >>Browse (to the downloaded software)

And it updated perfectly. Enjoy!

Also, I had two other driver issues, but I was able to install the two older drivers from the Dell Alienware 17 downloads:

1. ST Microelectronics Free Fall Sensor Driver

2. Alienware On Screen Display Application

Note: I identified the problem hardware by doing an internet search on the information listed in the Events tab of the device inside the Information box, e.g. ACPI\SMO8810\1 came back at the Dell Free Fall Sensor...

Top Contributor
Latest Solutions