Highlighted
Potatocat
1 Copper

M17x R4, games crashing, AGA to blame I think

I have an Alienware M17x R4 running a AGA (Alienware Graphics Amplifier) with a 1080 Ti video card.

Intel Core i7-7820HK CPU 2.90GHz
32GB ram
1080 Ti video card
BIOS Version 1.0.5

I was using GeForce experience to update the video drives and everything worked fine from August 2017 to February 2019 -the machine was running hot, so I updated all drivers from the dell support site and since then games crash. I believe it is the AGA as I have no crashes when I do not use the AGA and have the monitor plugged directly into the laptop. An example of the error I get is the Broccoli error on destiny 2 - https://www.bungie.net/en/Forums/Post/244958763?sort=0&page=0

I currently have the Dell Support driver installed onto the laptop, but when the AGA is plugged in - it shows version 419.67.

I have just paid a qualified engineer $150 to:

1. Open up machine, clean out all dust, reapply thermal pads and paste, check all hardware on laptop

2. Re-install all drivers in correct order after re-format ( which I did myself but thought I possibly messed up)

Good news is the machine is running 10 degrees Celsius cooler which was part of my goal

bad news is that hasn't solved crash issue - once again I am pretty sure it is the AGA.

Is it worth changing the cable? can i factory reset just the AGA - any ideas please?

Dan

Labels (3)
0 Kudos
1 Reply
Moderator
Moderator

Re: M17x R4, games crashing, AGA to blame I think

Hi @Potatocat

 

Private message answered.

 


Alienware Arena

Alienware-Eimy
Dell | Alienware Technical Support
#IWork4Dell
Opening your case does not void your warranty! Check out Alienware Artificial Intelligence
I can't always reply to PM's, if you need extra assistance visit: YouTube Logo Facebook Logo Twitter Logo

0 Kudos