Samsung 970 Pro on Alienware 17 R4 not supported?

Hi, I have Alienware 17 R4 below i will add the complete specs of my system. I have purchased Samsung V-Nand NVMe 970 Pro 1TB SSD and installed it on the system. The drive is detected in Computer Management and also the drive is accessible as a storage but when i installed Samsung Magician tool an error or a message flashed saying "This Drive is not supported" on which i tried installing the drivers of 970 pro from Samsung website which again it failed because it was unable to locate/find a NVMe SSD on my system. I tried running the Samsung cloning tool which again successfully completed cloning my OEM Toshiba 256 GB SSD to my New 970 Pro. but i am unable to boot using the new ssd drive. I am pretty confused on what has gone wrong and i am very newbie on this and need a solution for this Regards Dharam Kapadia Below i am mentioning the specs of my pc ------------------ System Information ------------------ Time of this report: 12/6/2018, 03:22:43 Machine name: DESKTOP-BQJCROB Machine Id: {} Operating System: Windows 10 Home 64-bit (10.0, Build 17134) (17134.rs4_release.180410-1804) Language: English (Regional Setting: English) System Manufacturer: Alienware System Model: Alienware 17 R4 BIOS: 1.5.0 (type: UEFI) Processor: Intel(R) Core(TM) i7-7820HK CPU @ 2.90GHz (8 CPUs), ~2.9GHz Memory: 32768MB RAM Available OS Memory: 32640MB RAM Page File: 10533MB used, 26971MB available Windows Dir: C:\WINDOWS DirectX Version: DirectX 12 DX Setup Parameters: Not found User DPI Setting: 144 DPI (150 percent) System DPI Setting: 144 DPI (150 percent) DWM DPI Scaling: UnKnown Miracast: Available, with HDCP Microsoft Graphics Hybrid: Not Supported DxDiag Version: 10.00.17134.0001 64bit Unicode ------------------------ Disk & DVD/CD-ROM Drives ------------------------ Drive: C: Free Space: 28.6 GB Total Space: 227.5 GB File System: NTFS Model: KXG50ZNV256G NVMe TOSHIBA 256GB Drive: D: Free Space: 942.1 GB Total Space: 953.7 GB File System: NTFS Model: HGST HTS721010A9E630 Drive: E: Free Space: 955.4 GB Total Space: 975.3 GB File System: NTFS Model: Samsung SSD 970 PRO 1TB
0 Kudos
3 Replies
JOcean
Platinum

Re: Samsung 970 Pro on Alienware 17 R4 not supported?

Enable AHCI in the BIOS (doing this will require re-installing Windows 10 in order to boot into Windows disconnect any other drives first). Disconnect any other drives when you install Windows 10. Disable SecureBoot in the BIOS. In boot order make sure that Windows Boot Manager is first.

http://www.tomshardware.com/answers/id-1634729/boot-switching-driver-ahci-windows.html




-Forum Member since 2016
-I do not work for Dell
-A user helping other users
-If you like an answer please click on thumbs up
-If a reply is a solution to your problem please click on Accept as Solution
Gaming on a home built ASUS Z170K i5 6600
Real work on an Inspiron 15 5575
0 Kudos
Techgee
Gold

Re: Samsung 970 Pro on Alienware 17 R4 not supported?

Samsung's NVMe driver and software only works in AHCI mode, not RAID.

Generally, you can switch on a live system by:

  1. Setting up to boot into Safe Mode on reboot, then
  2. On reboot before getting to Safe Mode go into BIOS and change from RAID to AHCI. 
  3. Boot into Safe Mode, then turn off Safe Mode and reboot. 

Basically Safe Mode will detect that you're in AHCI mode and switch to the right driver, provided it's installed.  This should pick up Microsoft's default AHCI driver.  If you're paranoid (or cautious), you can verify the AHCI driver is installed before attempting this.

If the above doesn't work, then reverse the procedure setting it back to RAID.  Note if necessary failing to boot Windows 3 times will put you in Safe Mode.  So, if you can't get back into Safe Mode:  Put it back into RAID mode in BIOS.  Fail 3 times rebooting.  This should put you into Safe Mode.  Turn off Safe Mode and reboot.  You should be back working normally with RAID.

Of course, make sure your data is backed up first...

0 Kudos

Re: Samsung 970 Pro on Alienware 17 R4 not supported?

970 works fine. If your using it as a storage drive, you dont have to do anything. IF your using it for your C-Drive, you need to redo windows and put it in AHCI.

0 Kudos