Highlighted
mirando
1 Copper

Can't use atmos-php with Code Igniter Framework on php 5.3

Two errors on php 5.3.3 (so far):

A PHP Error was encountered

Severity: 8192

Message: Assigning the return value of new by reference is deprecated

Filename: src/EsuRestApi.php

Line Number: 1354

A PHP Error was encountered

Severity: 8192

Message: Call-time pass-by-reference has been deprecated

Filename: src/EsuRestApi.php

Line Number: 1895

The first error refers to this line:

$req = &new HTTP_Request2( $url, $args );

resolution: remove the ampersand.

The second one refers to this line:

$this->parseReplicas( $dom->getElementsByTagName( "replica"), &$info->replicas );

resolution:  removed the ampersand.

EDIT - More errors:

Message:  Function split() is deprecated

Filename: src/EsuRestApi.php

Line Number: Somewhere near 1832 (I've been commenting out the deprecated lines & trying to fix, so line number is off by a few lines).

resolution: use explode() instead.

Labels (1)
0 Kudos
2 Replies
rbala1
3 Argentium

Re: Can't use atmos-php with Code Igniter Framework on php 5.3

Thanks for pointing this out.  Much appreciated.

Best,

Raj

0 Kudos
BrianOlson
1 Copper

Re: Can't use atmos-php with Code Igniter Framework on php 5.3

Hi Mirando,

What PHP wrappers are you using?    I fix these (and other) problems in the latest PHP wrappers v1.4.20 (released on November 27th).

You can download the latest PHP wrappers from here:  http://code.google.com/p/atmos-php/

Please let us know if this latest atmos-php distribution solves your observed problems...  and don't hesitate to post if you have more questions or comments!

Thanks!

Brian

0 Kudos