Katrina105
1 Copper

AVE can't deploy successfully on Hyper-V

Hi all,

I got some strange issue when I was deploying an AVE on Windows 2012 R2 Hyper-V server.

1. The document(Avamar Virtual Edition Installation and Upgrade Guide) on P.32 said that we need to use "createvhdfast.exe" to create VHDs then import AVE, but it just shows the messages about createvhdfast then nothing happened. no error messages and not even any VHD had been created.

The command has tried as bellow:

(1)M:\AAVE-18.2.0.134\createvhdfast\createvhdfast.exe -avetype=0.5T -basename=datadiskave -ds1=M:\AAVE-18.2.0.134\Virtual Hard Disks\datadiskave1 -ds2=M:\AAVE-18.2.0.134\Virtual Hard Disks\datadiskave2 -ds3=M:\AAVE-18.2.0.134\Virtual Hard Disks\datadiskave3

(2)M:\AAVE-19.1.0.38\createvhdfast\createvhdfast.exe -size=0.5T -path=M:\Virtual Hard Disks\ave\ave1.vhd

Image 2019-06-18_004.png

2. Even if AVE was created successfully through import AVE and create VHDs by Hyper-V Manager, the AVE can't boot successful and it's stuck at the process:
"import: <UNKNOWN> HID v0.01 Mouse [Microsoft Vmbus HID-compliant Mouse] on
done"

Image 2019-06-17_004.png

Does anyone know why it's happened? please help me! Thanks a lot ...

Reply
2 Replies
Highlighted
Ballantines123
1 Copper

Re: AVE can't deploy successfully on Hyper-V

Hello,

i have the same issue

You can try this one:

The host time synchronisation service can be disabled by navigating to Integration Services via the GUI as follows:

Hyper-V Manager > AVE Virtual Machine > Settings > Integration Services


Once there, locate the "Time synchronisation" box on the right hand side and un-check it as below, then click Apply.

===============================================================================

 

This seems to be due to the time synchronisation service offered by Hyper-V. If it is checked, the current time on the AVE is altered upon boot, making it believe the superblock was last mounted in the future.

The root cause of this issue is likely to be due to a problem with the specific host configuration, so this KB should be viewed as a temporary workaround for progressing the install.

Some form of time synchronisation will need to be set up properly later during the install to avoid issues with clock drift. This can be accomplished either by synchronising the AVE with an external Network Time Protocol (NTP) server, which is an optional step slightly later in the install process; or by re-enabling host time synchronisation later during the install.

Full recommendations for AVE time synchronisation can be found in the AVE for HyperV install guide, located here:
https://support.emc.com/docu81576_Avamar-Virtual-Edition-7.4-and-Service-Packs-for-HyperV-System-Ins...

 

Reply
Highlighted
Przemek_S
1 Copper

Re: AVE can't deploy successfully on Hyper-V

Hello,

I had the same issue a few times and solved it in the following way.

1. Please go to the AVE linux shell and switch to the root user

2. Use the command "mkinitrd"

3. The "mkinitrd" command will rebuild initrd image

It looks like, that on the Hyper-V platform initrd is corrupted and needs to be rebuilt

 

 

Reply