Highlighted
8 Krypton

Avamar GEN4S RMM Module Connection Problem

Jump to solution

Hello,

has someone experience with the RMM Modul in the Avamar GEN4S intel servers.

I have to install a lot of singel nodes and on most of them the connection to the dedicated rmm port don´t work.

I have set up it like follows:

ipmitool lan set 3 ipaddr IPADDR1

ipmitool lan set 3 netmask IPADDR2

ipmitool lan set 3 defgw ipaddr IPADDR3


But it is not possibe to ping them.

I tried to reset the BMC with


ipmitool mc reset cold/warm


No ping possible.


When I choose the shared option with the following command it works:


ipmitool lan set 1 ipaddr IPADDR1

ipmitool lan set 1 netmask IPADDR2

ipmitool lan set 1 defgw ipaddr IPADDR3


But this is not what I want, I want to use the dedicated port wich is on a special switch.


I have tested this configuration altough with a direct lan connection the the rmm port with the same result. So I can exclude that there are some network errors.


Any idea?


1 Solution

Accepted Solutions

Re: Avamar GEN4S RMM Module Connection Problem

Jump to solution

Hello,

This is New Bug 57366 with Intel.  The workaround in KB 172806 (at _https://support.emc.com/kb/172806 ) should be tried if this issue is encountered. 

Please find below all contents of KB mentioned above,

Issue

A connection to the RMM4 port cannot be established.

The IP address for the RMM4 port cannot be reached by ping.
Cables have been confirmed to be connected correctly.

Environment

Avamar Server 7.x
Avamar Server 6.1.1-87 and higher
Gen4s Hardware ONLY

Cause

There is an issue with BMC where the subnet mask information is not saved correctly.

Resolution

Workaround:
1. Confirm the ‘IP Address Source’ setting for lan 3 (dedicated) or lan 1 (shared). See APPENDIX A for sample output.

Note: Also record the 'IP Address', 'Subnet Mask' and 'Default Gateway IP'. It will be needed in a later step.

ipmitool lan print x

where x is 3 (dedicated) or 1 (shared). 

  1. a. If the value is 'static' then change to 'dhcp'.  Proceed to Step 2.

ipmitool lan set 3 ipsrc dhcp

  1. b. If the value is 'dhcp' then change to 'static'.  Proceed to Step 2.

ipmitool lan set 3 ipsrc static

  1. 2. Run the lan print command again.

ipmitool lan print x

  1. 3. Restore the settings back to the original values for ‘IP Address Source’, 'IP Address', 'Subnet Mask' and 'Default Gateway IP'.
  2. a. Revert the 'IP Address Source'.

Note: This is the value obtained in Step 1.

ipmitool lan set 3 ipsrc <value>

where value is either static or dhcp.

  1. b. Return

ipmitool lan set 3 ipaddr x.x.x.x

ipmitool lan set 3 netmask y.y.y.y

ipmitool lan set 3 defgw ipaddr z.z.z.z

  1. 4. Confirm RMM4 port connectivity (typically via the web console).


5. If the RMM4 port is still not available attempt the process a second time. Execute steps 1 through 4.

  1. 6. If the workaround does not resolve the issue please escalate per normal process.

Notes

APPENDIX A:
Sample output below shows output for a shared for a decicated (3) port.

ipmitool lan print 3

Set in Progress         : Set Complete

Auth Type Support       : MD5 PASSWORD

Auth Type Enable        : Callback : MD5 PASSWORD

  : User     : MD5 PASSWORD

  : Operator : MD5 PASSWORD

  : Admin    : MD5 PASSWORD

  : OEM      :

IP Address Source       : Static Address

IP Address              : 10.99.254.225

Subnet Mask             : 255.255.254.0

MAC Address             : 00:1e:67:59:63:90

SNMP Community String   : public

IP Header               : TTL=0x00 Flags=0x00 Precedence=0x00 TOS=0x00

BMC ARP Control         : ARP Responses Enabled, Gratuitous ARP Disabled

Gratituous ARP Intrvl   : 0.0 seconds

Default Gateway IP      : 10.99.254.1

Default Gateway MAC     : 00:00:00:00:00:00

Backup Gateway IP       : 0.0.0.0

Backup Gateway MAC      : 00:00:00:00:00:00

  1. 802.1q VLAN ID          : Disabled
  2. 802.1q VLAN Priority    : 0

RMCP+ Cipher Suites     : 0,1,2,3,4,6,7,8,9,11,12,13,15,16,17,18

Cipher Suite Priv Max   : caaaXaaaXaaXXaa

  :     X=Cipher Suite Unused

  :     c=CALLBACK

  :     u=USER

  :     o=OPERATOR

  :     a=ADMIN

  :     O=OEM

Please proceed with steps mentioned above, if you still having issues please escalate this to Support.

0 Kudos
5 Replies
gfznjhz
1 Copper

Re: Avamar GEN4S RMM Module Connection Problem

Jump to solution

Hi,

below, the screenshot of commands I've recently run on GEN4S node, and it worked fine :

root@AVMR:~/#: ipmitool lan set 3 ipaddr 192.168.9.203
Setting LAN IP Address to 192.168.9.203

root@AVMR:~/#: ipmitool lan set 3 netmask 255.255.255.0
Setting LAN Subnet Mask to 255.255.255.0

root@AVMR:~/#: ipmitool lan set 3 defgw ipaddr 192.168.9.254
Setting LAN Default Gateway IP to 192.168.9.254

root@AVMR:~/#: ipmitool lan print 3
Set in Progress         : Set Complete
Auth Type Support       : MD5 PASSWORD
Auth Type Enable        : Callback : MD5 PASSWORD
                        : User     : MD5 PASSWORD
                        : Operator : MD5 PASSWORD
                        : Admin    : MD5 PASSWORD
                        : OEM      :
IP Address Source       : Static Address
IP Address              : 192.168.9.203
Subnet Mask             : 255.255.255.0
MAC Address             : 00:1e:67:85:f5:b5
SNMP Community String   : public
IP Header               : TTL=0x00 Flags=0x00 Precedence=0x00 TOS=0x00
BMC ARP Control         : ARP Responses Enabled, Gratuitous ARP Disabled
Gratituous ARP Intrvl   : 0.0 seconds
Default Gateway IP      : 192.168.9.254
Default Gateway MAC     : 00:00:00:00:00:00
Backup Gateway IP       : 0.0.0.0
Backup Gateway MAC      : 00:00:00:00:00:00
802.1q VLAN ID          : Disabled
802.1q VLAN Priority    : 0
RMCP+ Cipher Suites     : 0,1,2,3,4,6,7,8,9,11,12,13,15,16,17,18
Cipher Suite Priv Max   : caaaaaaaaaaaaaa
                        :     X=Cipher Suite Unused
                        :     c=CALLBACK
                        :     u=USER
                        :     o=OPERATOR
                        :     a=ADMIN
                        :     O=OEM

You can match with results of your commands.

Regards,

Andy

0 Kudos
8 Krypton

Re: Avamar GEN4S RMM Module Connection Problem

Jump to solution

Hi,

The output is the same as You posted. But try a ping to the RMM adress it dont work.

0 Kudos

Re: Avamar GEN4S RMM Module Connection Problem

Jump to solution

Hello,

This is New Bug 57366 with Intel.  The workaround in KB 172806 (at _https://support.emc.com/kb/172806 ) should be tried if this issue is encountered. 

Please find below all contents of KB mentioned above,

Issue

A connection to the RMM4 port cannot be established.

The IP address for the RMM4 port cannot be reached by ping.
Cables have been confirmed to be connected correctly.

Environment

Avamar Server 7.x
Avamar Server 6.1.1-87 and higher
Gen4s Hardware ONLY

Cause

There is an issue with BMC where the subnet mask information is not saved correctly.

Resolution

Workaround:
1. Confirm the ‘IP Address Source’ setting for lan 3 (dedicated) or lan 1 (shared). See APPENDIX A for sample output.

Note: Also record the 'IP Address', 'Subnet Mask' and 'Default Gateway IP'. It will be needed in a later step.

ipmitool lan print x

where x is 3 (dedicated) or 1 (shared). 

  1. a. If the value is 'static' then change to 'dhcp'.  Proceed to Step 2.

ipmitool lan set 3 ipsrc dhcp

  1. b. If the value is 'dhcp' then change to 'static'.  Proceed to Step 2.

ipmitool lan set 3 ipsrc static

  1. 2. Run the lan print command again.

ipmitool lan print x

  1. 3. Restore the settings back to the original values for ‘IP Address Source’, 'IP Address', 'Subnet Mask' and 'Default Gateway IP'.
  2. a. Revert the 'IP Address Source'.

Note: This is the value obtained in Step 1.

ipmitool lan set 3 ipsrc <value>

where value is either static or dhcp.

  1. b. Return

ipmitool lan set 3 ipaddr x.x.x.x

ipmitool lan set 3 netmask y.y.y.y

ipmitool lan set 3 defgw ipaddr z.z.z.z

  1. 4. Confirm RMM4 port connectivity (typically via the web console).


5. If the RMM4 port is still not available attempt the process a second time. Execute steps 1 through 4.

  1. 6. If the workaround does not resolve the issue please escalate per normal process.

Notes

APPENDIX A:
Sample output below shows output for a shared for a decicated (3) port.

ipmitool lan print 3

Set in Progress         : Set Complete

Auth Type Support       : MD5 PASSWORD

Auth Type Enable        : Callback : MD5 PASSWORD

  : User     : MD5 PASSWORD

  : Operator : MD5 PASSWORD

  : Admin    : MD5 PASSWORD

  : OEM      :

IP Address Source       : Static Address

IP Address              : 10.99.254.225

Subnet Mask             : 255.255.254.0

MAC Address             : 00:1e:67:59:63:90

SNMP Community String   : public

IP Header               : TTL=0x00 Flags=0x00 Precedence=0x00 TOS=0x00

BMC ARP Control         : ARP Responses Enabled, Gratuitous ARP Disabled

Gratituous ARP Intrvl   : 0.0 seconds

Default Gateway IP      : 10.99.254.1

Default Gateway MAC     : 00:00:00:00:00:00

Backup Gateway IP       : 0.0.0.0

Backup Gateway MAC      : 00:00:00:00:00:00

  1. 802.1q VLAN ID          : Disabled
  2. 802.1q VLAN Priority    : 0

RMCP+ Cipher Suites     : 0,1,2,3,4,6,7,8,9,11,12,13,15,16,17,18

Cipher Suite Priv Max   : caaaXaaaXaaXXaa

  :     X=Cipher Suite Unused

  :     c=CALLBACK

  :     u=USER

  :     o=OPERATOR

  :     a=ADMIN

  :     O=OEM

Please proceed with steps mentioned above, if you still having issues please escalate this to Support.

0 Kudos
badger68
1 Copper

Re: Avamar GEN4S RMM Module Connection Problem

Jump to solution

If the method above does not work, please power down the node and then disconnect both power cables for 60 seconds to drain the power and reset BMC. This method works in 99% of the cases for the RMM problems.

0 Kudos
8 Krypton

Re: Avamar GEN4S RMM Module Connection Problem

Jump to solution

How Can we create a new user for ipmitool to login.

0 Kudos